<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://www.305sports.net/xmlrpc.php" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="The disappointment factor is definitely there. Brian Flores&#8217; 1-3 start to the season has been a shocking one for himself, to say the least. Now possessing a 6-14 record as head coach of the Miami Dolphins, while there&#8217;s no urgent expectations of a winning campaign, many, including himself, are not proud of the early-season positioning [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/"><meta name="twitter:title" content="&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season"><meta name="twitter:description" content="The disappointment factor is definitely there. Brian Flores&#8217; 1-3 start to the season has been a shocking one for himself, to say the least. Now possessing a 6-14 record as head coach of the Miami Dolphins, while there&#8217;s no urgent expectations of a winning campaign, many, including himself, are not proud of the early-season positioning [&hellip;]"> <script>var et_site_url='https://www.305sports.net';var et_post_id='21531';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script> <!-- This site is optimized with the Yoast SEO plugin v14.8 - https://yoast.com/wordpress/plugins/seo/ --><style media="all">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</style><title>&#039;We Have To Finish Better&#039;: Where The Dolphins Stand 4 Games Into The Season - 305Sports</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="&#039;We Have To Finish Better&#039;: Where The Dolphins Stand 4 Games Into The Season - 305Sports" /><meta property="og:description" content="The disappointment factor is definitely there. Brian Flores&#8217; 1-3 start to the season has been a shocking one for himself, to say the least. Now possessing a 6-14 record as head coach of the Miami Dolphins, while there&#8217;s no urgent expectations of a winning campaign, many, including himself, are not proud of the early-season positioning [&hellip;]" /><meta property="og:url" content="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/" /><meta property="og:site_name" content="305Sports" /><meta property="article:published_time" content="2020-10-06T03:21:11+00:00" /><meta property="article:modified_time" content="2020-10-06T03:53:19+00:00" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg" /><meta property="og:image:width" content="480" /><meta property="og:image:height" content="270" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@https://twitter.com/MichaelYero" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.305sports.net/#website","url":"https://www.305sports.net/","name":"305Sports","description":"Providing In-Depth Analysis And Coverage Of Miami Sports.","potentialAction":[{"@type":"SearchAction","target":"https://www.305sports.net/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/#primaryimage","inLanguage":"en-US","url":"https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg","width":480,"height":270,"caption":"Miami Dolphins head coach Brian Flores speaks with quarterback Ryan Fitzpatrick (14) on the sidelines in the fourth quarter against the Seattle Seahawks at Hard Rock Stadium in Miami Gardens on Sunday, October 4, 2020."},{"@type":"WebPage","@id":"https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/#webpage","url":"https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/","name":"'We Have To Finish Better': Where The Dolphins Stand 4 Games Into The Season - 305Sports","isPartOf":{"@id":"https://www.305sports.net/#website"},"primaryImageOfPage":{"@id":"https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/#primaryimage"},"datePublished":"2020-10-06T03:21:11+00:00","dateModified":"2020-10-06T03:53:19+00:00","author":{"@id":"https://www.305sports.net/#/schema/person/a794839bf7e848ad00664956c5077b0a"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/"]}]},{"@type":"Person","@id":"https://www.305sports.net/#/schema/person/a794839bf7e848ad00664956c5077b0a","name":"Michael Yero","image":{"@type":"ImageObject","@id":"https://www.305sports.net/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=96&d=mm&r=g","caption":"Michael Yero"},"description":"Michael Yero covers the Miami Heat, Miami Hurricanes, Miami Dolphins and South Florida High School sports for 305Sports. He\u2019s born and raised in Miami, currently attending Immaculata LaSalle High School.","sameAs":["https://www.instagram.com/michael.yero/","https://twitter.com/https://twitter.com/MichaelYero"]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Feed" href="https://www.305sports.net/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Comments Feed" href="https://www.305sports.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; &#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season Comments Feed" href="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.305sports.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style type="text/css">#wpadminbar #wp-admin-bar-my-networks > .ab-item:first-child:before {
                content: "\f325";
                top: 3px;
            }</style><style id='mvp-custom-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /> <script type='text/javascript' src='https://www.305sports.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-156579328-1'></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-156579328-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.305sports.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.305sports.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.305sports.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.305sports.net/?p=21531' /><link rel="alternate" type="application/json+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#f890e7";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <meta name="generator" content="Site Kit by Google 1.14.0" /><script data-ad-client="ca-pub-9318763060154915" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- VINTCER_DO_NOT_REMOVE --> <script type="text/javascript">var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.www.305sports.net"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//vint-analytics.vintcer.io/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '5']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();</script> <!-- VINTCER_DO_NOT_REMOVE --><meta property="fb:app_id" content=""><meta property="fb:admins" content=""><div id="fb-root"></div> <script>(function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id))
                        return;
                    js = d.createElement(s);
                    js.id = id;
                    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
                    fjs.parentNode.insertBefore(js, fjs);
                }(document, 'script', 'facebook-jssdk'));</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9318763060154915",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-180x180.png" /><meta name="msapplication-TileImage" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-270x270.png" /> <script src="https://www.305sports.net/wp-content/cache/autoptimize/6/js/autoptimize_d01ef3aa366168ff6e08c3faf50e1dfa.js"></script></head><body class="post-template-default single single-post postid-21531 single-format-standard et_bloom"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a></div><!--mvp-fly-logo--></div><!--mvp-fly-top-in--><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-fly-top-out--></div><!--mvp-fly-menu-top--><div id="mvp-fly-menu-wrap"><nav class="mvp-fly-nav-menu left relative"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li id="menu-item-6263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li id="menu-item-12213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li id="menu-item-12212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li id="menu-item-9011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li id="menu-item-4263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li id="menu-item-8714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li id="menu-item-8951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li id="menu-item-8952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li id="menu-item-8953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU</a></li></ul></li></ul></div></nav></div><!--mvp-fly-menu-wrap--><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-fly-soc-wrap--></div><!--mvp-fly-wrap--><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://www.305sports.net/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><!--mvp-search-box--><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div><!--mvp-search-but-wrap--></div><!--mvp-search-wrap--><header id="mvp-top-head-wrap"><nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-top-nav-menu-but--><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://www.305sports.net/"><img itemprop="logo" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a><h2 class="mvp-logo-title">305Sports</h2></div><!--mvp-top-nav-logo--></div><!--mvp-top-nav-left-in--></div><!--mvp-top-nav-left-out--></div><!--mvp-top-nav-left--></div><!--mvp-top-nav-right-in--><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="https://www.instagram.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/305Sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://www.facebook.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div><!--mvp-top-nav-soc--> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div><!--mvp-top-nav-right--></div><!--mvp-top-nav-right-out--></div><!--mvp-top-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-top-nav-wrap--><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-primary-container"><ul id="menu-primary-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU</a></li></ul></li></ul></div></div><!--mvp-nav-menu--></div><!--mvp-bot-nav-in--></div><!--mvp-bot-nav-out--></div><!--mvp-bot-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-bot-nav-wrap--></nav><!--mvp-main-nav-wrap--></header><main id="mvp-main-wrap" class="left relative"><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-21531 post type-post status-publish format-standard has-post-thumbnail hentry category-miami-dolphins tag-brian-flores tag-featured tag-miami-dolphins tag-nfl tag-noah-igbinoghene tag-ryan-fitzpatrick tag-tua-tagovailoa" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/"/><div id="mvp-article-head" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.305sports.net/category/miami-dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season</h1><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.305sports.net/author/michaelyero/" title="Posts by Michael Yero" rel="author">Michael Yero</a></span></li><li class="mvp-author-info-twit"> <a href="https://twitter.com/MichaelYero" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-10-05">October 5, 2020</time></span><meta itemprop="dateModified" content="2020-10-05"/></li></ul></div><!--mvp-author-info-wrap--></div><!--mvp-article-head--><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/&amp;t=&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season -&amp;url=https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg&amp;description=&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#e6d99593848c838592dbc0c5ded4d7d0ddb183c6ae879083c6b289c6a08f888f958ec6a48392928394c0c5ded4d7d1dddcc6b18e839483c6b28e83c6a2898a968e8f8895c6b592878882c6d2c6a1878b8395c6af889289c6b28e83c6b58387958988c0878b96dda4a9a2bfdbafc68089938882c6928e8f95c68794928f858a83c68f889283948395928f8881c6878882c6928e8993818e92c68980c6958e87948f8881c68f92c6918f928ec69f8993c8c6a58e83858dc68f92c6899392dcc68e92929695dcc9c9919191c8d5d6d3959689949295c8888392c99183cb8e879083cb9289cb808f888f958ecb848392928394cb918e839483cb928e83cb82898a968e8f8895cb9592878882cbd2cb81878b8395cb8f889289cb928e83cb958387958988c9"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/#respond"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="480" height="270" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg 480w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9-300x169.jpg 300w" sizes="(max-width: 480px) 100vw, 480px" /><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg"><meta itemprop="width" content="480"><meta itemprop="height" content="270"></div><!--mvp-post-feat-img--> <span class="mvp-feat-caption">Creator: Charles Trainor Jr |  Credit: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="2f4c5b5d4e4641405d6f42464e4246474a5d4e434b014c4042">[email&#160;protected]</a></span><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/" data-a2a-title="‘We Have To Finish Better’: Where The Dolphins Stand 4 Games Into The Season"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><style>.fb_iframe_widget span{width:460px !important;} .fb_iframe_widget iframe {margin: 0 !important;}        .fb_edge_comment_widget { display: none !important; }</style><div style="width:100%; text-align:left"><div class="fb-like" style="width:450px; overflow: hidden !important; " data-href="https://www.facebook.com/305sportss/" data-size="small" data-colorscheme="light" data-width="450" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false" kid_directed_site="false"></div></div><p>The disappointment factor is definitely there. Brian Flores&#8217; 1-3 start to the season has been a shocking one for himself, to say the least.</p><p>Now possessing a 6-14 record as head coach of the <a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a>, while there&#8217;s no urgent expectations of a winning campaign, many, including himself, are not proud of the early-season positioning they&#8217;ve been placed in.</p><p>Still, there&#8217;s hope for a successful road ahead.</p><p>&#8220;We take this one game at a time,&#8221; Flores said one day after the Dolphins&#8217; 31-23 loss to the Seattle Seahawks Sunday at Hard Rock Stadium.  &#8220;&#8230; If we start thinking down the road it&#8217;s probably not gonna help us all that much.&#8221;</p><p>Miami failed to score a touchdown until 1:50 left in the fourth quarter, failing to respond at a Russell Wilson led offense which scored 14 unanswered points in the final period. Instead, the Dolphins put their trust in the hands of kicker Jason Sanders, who nailed all 5 of his field-goal attempts.</p><p>One of those drives came back to bite the Dolphins, however. Placed at the Seattle 9-yard-line on 3rd and 3, Flores and his staff choose to hand it to Myles Gaskin, who lost 2-yards and would result in a 4th and 5.</p><p>Instead of going for it, considering that the score was 17-12 Seahawks with under eight minutes to play, Miami settled with three points instead of a big-time play with a significant opportunity cost.</p><p>Wilson and Seattle ultimately put the nail in the coffin, as they moved to 4-0 on the season.</p><p>&#8220;We felt like we stopped them a couple times prior to that, so we felt like that was the best move right there,&#8221; Flores said. &#8220;In hindsight, you can look at it given the score, given the way the rest of the game went. You can sit there and say hey, you probably should&#8217;ve done this, that or the other thing.&#8221;</p><p>Now entering Week 5 of the season versus the reigning NFC East champion San Francisco 49ers, there a lot at stake in terms of how the remainder of the season could pan out for the Dolphins.</p><p>That being said, here&#8217;s where Miami stands with a quarter of the season gone by.</p><h4><strong>1.)  Fourth quarters struggles remain critical to lossing woes.</strong></h4><p>Finishing games have been a remaining issue for the club early on. Whether it be on the offensive or defensive side, Miami has dealt with constant tendencies that keep them from outmatching opponents.</p><p>Against the New England Patriots, it was a mix of Cam Newton&#8217;s ground game that helped extend the duration of possessions and an unnecessary roughness foul by Jerome Baker. Such sequences prevented the Dolphins from having Ryan Fitzpatrick and his group attempt to score with an opportunity to take the lead.</p><p>Then versus the Buffalo Bills, a cross-route on a crucial 3rd and 9 resulted in a 46-yard passing touchdown from Josh Allen to wide receiver John Brown. The score gave the Bills a 31-20 lead with 3:09 left in the fourth quarter, as Miami&#8217;s defense blew their 20-17 lead and the offense failed to put more points on the board.</p><p>Once again in Sunday&#8217;s contest, a combination of poor red-zone execution and a costly secondary mistakes allowed Seattle to make a once 17-15 lead to 31-15 in a span of 4 minutes and 15 seconds.</p><p>&#8220;It starts with me,&#8221; Flores said. &#8220;I gotta coach it better and we gotta play better, try to put an emphasis on playing our best in the fourth quarter. We didn&#8217;t do that. Every game it&#8217;s been close in the fourth quarter. We have to finish better.&#8221;</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">INCREDIBLE. <a href="https://twitter.com/DangeRussWilson?ref_src=twsrc%5Etfw">@DangeRussWilson</a>. <a href="https://twitter.com/DmoeSwagg23?ref_src=twsrc%5Etfw">@DmoeSwagg23</a>. 17-yard <a href="https://twitter.com/Seahawks?ref_src=twsrc%5Etfw">@Seahawks</a> TD in Miami.<br><br>📺: <a href="https://twitter.com/hashtag/SEAvsMIA?src=hash&amp;ref_src=twsrc%5Etfw">#SEAvsMIA</a> on FOX<br>📱: NFL app // Yahoo Sports app: <a href="https://t.co/T1i6s2rIdv">https://t.co/T1i6s2rIdv</a> <a href="https://t.co/CDQFCALRwL">pic.twitter.com/CDQFCALRwL</a></p>&mdash; NFL (@NFL) <a href="https://twitter.com/NFL/status/1312840896086327296?ref_src=twsrc%5Etfw">October 4, 2020</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h4><strong>2.) There&#8217;s no pressure to implement Tagovailoa.</strong></h4><p>Despite the inconsistent play from Ryan Fitzpatrick, who&#8217;s already racked up five interceptions, tied for 29th in the NFL, there seems to be no immediate rush to get Alabama rookie Tua Tagovailoa on the field.</p><p>As worded by coach Flores, while he&#8217;s ready and healthy to go, he won&#8217;t let pressure to get his highly-touted quarterback to cover ground for Miami&#8217;s offense.</p><p>&#8220;He&#8217;s checked all the boxes from a medical standpoint. He has,&#8221; Flores said. &#8220;Look, the honest thing for me is if it was my kid, and he had a serious injury like that, I wouldn&#8217;t want his coach to throw him in there because of media pressure or anything like that. That&#8217;s kind of how I approach this situation and really all situations. The players, essentially, they are my kids. So no one is going to pressure me into doing anything. When we feel like he&#8217;s ready to go, we&#8217;ll put him in.&#8221;</p><p>While Flores wouldn&#8217;t clarify Miami&#8217;s starter for Week 5&#8217;s game against the 49ers, he did &#8220;presume it&#8217;s going to be Fitzpatrick.&#8221;</p><p>The veteran quarterback seemingly looks to remain part of the Dolphins&#8217; starting group, although that patience could be dwindling on a game-by-game basis. Ultimately, it seems as if Miami will hand Tagovailoa the keys to their offense once they could assure him a permanent spot as the starting signal-caller.</p><p>For now, he&#8217;ll have to remain No. 2 on the depth chart.</p><figure class="wp-block-image size-large"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/292e1a10-0046-11eb-bbfe-0c2bcb16997c.jpg" alt="" class="wp-image-21570" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/292e1a10-0046-11eb-bbfe-0c2bcb16997c.jpg 800w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/292e1a10-0046-11eb-bbfe-0c2bcb16997c-300x200.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/292e1a10-0046-11eb-bbfe-0c2bcb16997c-768x512.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/292e1a10-0046-11eb-bbfe-0c2bcb16997c-610x406.jpg 610w" sizes="(max-width: 800px) 100vw, 800px" /><figcaption>Photo Credit: (AP Photo/Phelan M. Ebenhack)</figcaption></figure><h4><strong>3.) The Igbinoghene show must go on.</strong></h4><p>Hate all you want, Noah Igbinoghene deserves more praise than people expect. At 20-years-old, the first-round pick out of Auburn is the youngest player in the NFL, and is starting at cornerback for a Dolphins secondary that hasn&#8217;t lived to its expectations.</p><p>Igbinoghene has been forced to replace Byron Jones, who&#8217;s sidelined with a groin injury he sustained in the first quarter of Miami&#8217;s Week 2 loss versus the Bills. Since then, he&#8217;s been tasked with defending some of the top receivers in the league, including Stefon Diggs &#8212; 153 yards, 1 touchdown &#8212; and David Moore &#8212; 95 yards, 1 touchdown.</p><p>Moore was a vital piece in Seattle&#8217;s success Sunday, as Igbinoghene bit on Wilson and gave the receiver enough space for a 57-yard gain. That play set the tone for a 4 play, 75-yard possession for a touchdown in just 21 seconds.</p><p>Then with under six minutes to play, the rookie failed to stick with Moore, resulting in a leaping catch for a touchdown, extending Seattle&#8217;s lead to two possessions. After the game, coach Flores addressed Igbinoghene&#8217;s errors, understanding that it&#8217;s part of the game.</p><p>&#8220;He’s a rookie, he’s going to have his ups and downs,&#8221; he said. &#8220;Last week he played well. This week he didn’t play well. Two weeks ago he didn’t play … He’s a resilient kid. He’s a talented kid. He’s got to learn from this. We’ll help him. We’ll coach him, and I think he’ll get better.&#8221;</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">.<a href="https://twitter.com/DangeRussWilson?ref_src=twsrc%5Etfw">@dangerusswilson</a> to <a href="https://twitter.com/DmoeSwagg23?ref_src=twsrc%5Etfw">@DmoeSwagg23</a> for 57 yards!<br><br>📺: <a href="https://twitter.com/hashtag/SEAvsMIA?src=hash&amp;ref_src=twsrc%5Etfw">#SEAvsMIA</a> on FOX<br>📱: NFL app // Yahoo Sports app: <a href="https://t.co/T1i6s2rIdv">https://t.co/T1i6s2rIdv</a> <a href="https://t.co/fWCJO2hNyk">pic.twitter.com/fWCJO2hNyk</a></p>&mdash; NFL (@NFL) <a href="https://twitter.com/NFL/status/1312822041515499520?ref_src=twsrc%5Etfw">October 4, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h4><strong>4.) It&#8217;s about time Miami notches an upset victory.</strong></h4><p>Just imagine what a road victory against a 49ers team could do to Miami&#8217;s morale as they continue playing non-divisional teams for weeks on end. The opportunity could spark a fire for the Dolphins, allowing for them to keep their postseason hopes alive.</p><p>At the end of the day, while it&#8217;s still early on in the season, Miami has already exceeded their room for error, as there positioning projects them to have a top-five draft pick for the second consecutive season.</p><p>That could change this upcoming Sunday. Even though San Francisco is banged up, the ability to compete with a highly-touted club is nothing short of a confidence booster for the Dolphins.</p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/" data-a2a-title="‘We Have To Finish Better’: Where The Dolphins Stand 4 Games Into The Season"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fwe-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season%2F&amp;linkname=%E2%80%98We%20Have%20To%20Finish%20Better%E2%80%99%3A%20Where%20The%20Dolphins%20Stand%204%20Games%20Into%20The%20Season" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.305sports.net/tag/brian-flores/" rel="tag">Brian Flores</a><a href="https://www.305sports.net/tag/featured/" rel="tag">featured</a><a href="https://www.305sports.net/tag/miami-dolphins/" rel="tag">Miami Dolphins</a><a href="https://www.305sports.net/tag/nfl/" rel="tag">NFL</a><a href="https://www.305sports.net/tag/noah-igbinoghene/" rel="tag">Noah Igbinoghene</a><a href="https://www.305sports.net/tag/ryan-fitzpatrick/" rel="tag">Ryan Fitzpatrick</a><a href="https://www.305sports.net/tag/tua-tagovailoa/" rel="tag">Tua Tagovailoa</a></span></div><!--mvp-post-tags--><div class="posts-nav-link"></div><!--posts-nav-link--><div id="mvp-author-box-wrap" class="left relative"><div class="mvp-author-box-out right relative"><div id="mvp-author-box-img" class="left relative"> <img alt='' src='https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></div><!--mvp-author-box-img--><div class="mvp-author-box-in"><div id="mvp-author-box-head" class="left relative"> <span class="mvp-author-box-name left relative"><a href="https://www.305sports.net/author/michaelyero/" title="Posts by Michael Yero" rel="author">Michael Yero</a></span><div id="mvp-author-box-soc-wrap" class="left relative"> <a href="https://twitter.com/MichaelYero" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a> <a href="https://www.instagram.com/michael.yero/" alt="Instagram" target="_blank"><span class="mvp-author-box-soc fa fa-instagram fa-2"></span></a></div><!--mvp-author-box-soc-wrap--></div><!--mvp-author-box-head--></div><!--mvp-author-box-in--></div><!--mvp-author-box-out--><div id="mvp-author-box-text" class="left relative"><p>Michael Yero covers the Miami Heat, Miami Hurricanes, Miami Dolphins and South Florida High School sports for 305Sports. He’s born and raised in Miami, currently attending Immaculata LaSalle High School.</p></div><!--mvp-author-box-text--></div><!--mvp-author-box-wrap--><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"/><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"></div><!--mvp-org-logo--><meta itemprop="name" content="305Sports"></div><!--mvp-org-wrap--></div><!--mvp-content-main--><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text">Click to comment</span></div><!--mvp-comments-button--><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.305sports.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p><p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='21531' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!--comments--></div><!--mvp-post-soc-in--></div><!--mvp-post-soc-out--></div><!--mvp-content-box--></div><!--mvp-post-content--></div><!--mvp-post-content-in--><div id="mvp-side-wrap" class="relative"></div><!--mvp-side-wrap--></div><!--mvp-post-content-out--><section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Miami Dolphins</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://www.305sports.net/yero-why-its-time-to-put-some-respect-on-devante-parkers-name/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/4352B0F7-68BC-4C2C-BAF2-D0F827FE9050-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/4352B0F7-68BC-4C2C-BAF2-D0F827FE9050-400x240.jpeg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/4352B0F7-68BC-4C2C-BAF2-D0F827FE9050-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/4352B0F7-68BC-4C2C-BAF2-D0F827FE9050-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/4352B0F7-68BC-4C2C-BAF2-D0F827FE9050-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/4352B0F7-68BC-4C2C-BAF2-D0F827FE9050-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/yero-why-its-time-to-put-some-respect-on-devante-parkers-name/" rel="bookmark">Yero: Why It&#8217;s Time To Put Some Respect On DeVante Parker&#8217;s Name</a></h2><p>It&#8217;s time to put some respect on DeVante Parker&#8217;s name. Dating back to 2019,...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/poll-checking-the-pulse-of-dolphins-fans-after-4-games/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/poll-checking-the-pulse-of-dolphins-fans-after-4-games/" rel="bookmark">Poll: Checking The Pulse Of Dolphins Fans After 4 Games</a></h2><p>A recent Twitter poll revealed that the majority of Miami Dolphins fans feel as...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/ramos-dolphins-defense-make-strides-against-undefeated-seahawks/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/ramos-dolphins-defense-make-strides-against-undefeated-seahawks/" rel="bookmark">Ramos: Dolphins’ Defense Makes Strides Against Undefeated Seahawks</a></h2><p>After notching their first win of the season, Brian Flores’ Dolphins welcomed a Russell...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/dolphins-seahawks-could-miami-spoil-russell-wilsons-parade/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-400x240.jpeg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/dolphins-seahawks-could-miami-spoil-russell-wilsons-parade/" rel="bookmark">Dolphins-Seahawks: Could Miami Spoil Russell Wilson&#8217;s Parade?</a></h2><p>The Dolphins are fresh off a primetime road victory in Week 3 and are...</p></div><!--mvp-more-post-text--></li></ul></section><!--mvp-more-post-wrap--><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/poll-checking-the-pulse-of-dolphins-fans-after-4-games/" rel="prev">Poll: Checking The Pulse Of Dolphins Fans After 4 Games</a></div><!--mvp-prev-post-text--></div><!--mvp-prev-post-wrap--><div id="mvp-next-post-wrap"><div id="mvp-next-post-arrow" class="relative"> <span class="fa fa-angle-right fa-4 " aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/yero-why-its-time-to-put-some-respect-on-devante-parkers-name/" rel="next">Yero: Why It&#8217;s Time To Put Some Respect On DeVante Parker&#8217;s Name</a></div><!--mvp-prev-next-text--></div><!--mvp-next-post-wrap--></div><!--mvp-prev-next-wrap--></div><!--mvp-sec-pad--></article><!--mvp-article-wrap--></div><!--mvp-main-body--></div><!--mvp-main-box-cont--></div><!--mvp-main-body-wrap--></main><!--mvp-main-wrap--><footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="" alt="305Sports" data-rjs="2" /></a></div><!--mvp-foot-logo--><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-foot-soc--></div><!--mvp-main-box-cont--></div><!--mvp-foot-top--><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"></div><!--mvp-foot-menu--></div><!--mvp-main-box-cont--></div><!--mvp-foot-menu-wrap--><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>305 SPORTS ENTERPRISES, INC.</p></div><!--mvp-foot-copy--></div><!--mvp-main-box-cont--></div><!--mvp-foot-copy-wrap--></div><!--mvp-foot-bot--></footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/&amp;t=&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season -&amp;url=https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/we-have-to-finish-better-where-the-dolphins-stand-4-games-into-the-season/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/10/image-9.jpg&amp;description=&#8216;We Have To Finish Better&#8217;: Where The Dolphins Stand 4 Games Into The Season', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#8ab5f9ffe8e0efe9feb7aca9b2b8bbbcb1ddefaac2ebfcefaadee5aacce3e4e3f9e2aac8effefeeff8aca9b2b8bbbdb1b0aadde2eff8efaadee2efaacee5e6fae2e3e4f9aad9feebe4eeaabeaacdebe7eff9aac3e4fee5aadee2efaad9efebf9e5e4acebe7fab1c8c5ced3b7c3aaece5ffe4eeaafee2e3f9aaebf8fee3e9e6efaae3e4feeff8eff9fee3e4edaaebe4eeaafee2e5ffede2feaae5ecaaf9e2ebf8e3e4edaae3feaafde3fee2aaf3e5ffa4aac9e2efe9e1aae3feaae5fffeb0aae2fefefaf9b0a5a5fdfdfda4b9babff9fae5f8fef9a4e4effea5fdefa7e2ebfcefa7fee5a7ece3e4e3f9e2a7e8effefeeff8a7fde2eff8efa7fee2efa7eee5e6fae2e3e4f9a7f9feebe4eea7bea7edebe7eff9a7e3e4fee5a7fee2efa7f9efebf9e5e4a5"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--></div><!--mvp-site--><div id="mvp-post-trend-wrap"><div class="mvp-main-box-cont relative"><ul class="mvp-post-trend-list left relative"><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/poll-checking-the-pulse-of-dolphins-fans-after-4-games/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/nfl-makes-changes-stadium-crowd-noise-audio-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/poll-checking-the-pulse-of-dolphins-fans-after-4-games/" rel="bookmark">Poll: Checking The Pulse Of Dolphins Fans After 4 Games</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/ramos-dolphins-defense-make-strides-against-undefeated-seahawks/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/0E934B0F-1628-436E-AE82-0A9DD4010462-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/ramos-dolphins-defense-make-strides-against-undefeated-seahawks/" rel="bookmark">Ramos: Dolphins’ Defense Makes Strides Against Undefeated Seahawks</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/dolphins-seahawks-could-miami-spoil-russell-wilsons-parade/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/C82AE544-4C51-4157-A4BB-BC5D774A331F-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/dolphins-seahawks-could-miami-spoil-russell-wilsons-parade/" rel="bookmark">Dolphins-Seahawks: Could Miami Spoil Russell Wilson&#8217;s Parade?</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/adebayos-shoulder-injury-opens-the-door-for-olynyk-leonard-to-shine/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/unnamed-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/10/unnamed-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/10/unnamed-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Heat</h3> <a href="https://www.305sports.net/adebayos-shoulder-injury-opens-the-door-for-olynyk-leonard-to-shine/" rel="bookmark">Adebayo&#8217;s Shoulder Injury Opens The Door For Olynyk, Leonard To Shine</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li></ul> <span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span></div><!--mvp-main-box-cont--></div><!--mvp-post-trend-wrap--><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><!--mvp-fly-top--><div class="mvp-fly-fade mvp-fly-but-click"></div><!--mvp-fly-fade--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>/* <![CDATA[ */
var mdp_deblocker = {"style":"compact","timeout":"0","closeable":"true","title":"It Looks Like You Have AdBlocker Enabled","content":"<p>Please disable AdBlock to proceed to the destination page.<p>","bg_color":"rgba(0,0,0,0.65)","modal_color":"rgba(255,255,255,1)","text_color":"#23282d","blur":"true"};
/* ]]> */</script> <script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script> </body></html>