<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://www.305sports.net/xmlrpc.php" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="The Miami Dolphins have selected former USC offensive tackle Austin Jackson with the 18th overall pick in the 2020 NFL Draft.&nbsp; Austin Jackson, (6-foot-4, 322 lbs) fills the Dolphins needs at the offensive-line position to protect Miami&#8217;s recent addition in quarterback Tua Tagovailoa. He has an aggressive play style in which he initiates contact with [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/"><meta name="twitter:title" content="Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft"><meta name="twitter:description" content="The Miami Dolphins have selected former USC offensive tackle Austin Jackson with the 18th overall pick in the 2020 NFL Draft.&nbsp; Austin Jackson, (6-foot-4, 322 lbs) fills the Dolphins needs at the offensive-line position to protect Miami&#8217;s recent addition in quarterback Tua Tagovailoa. He has an aggressive play style in which he initiates contact with [&hellip;]"> <script>var et_site_url='https://www.305sports.net';var et_post_id='6652';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script><style media="all">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</style><title>Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft - 305Sports</title> <!-- This site is optimized with the Yoast SEO plugin v13.4 - https://yoast.com/wordpress/plugins/seo/ --><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft - 305Sports" /><meta property="og:description" content="The Miami Dolphins have selected former USC offensive tackle Austin Jackson with the 18th overall pick in the 2020 NFL Draft.&nbsp; Austin Jackson, (6-foot-4, 322 lbs) fills the Dolphins needs at the offensive-line position to protect Miami&#8217;s recent addition in quarterback Tua Tagovailoa. He has an aggressive play style in which he initiates contact with &hellip;" /><meta property="og:url" content="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/" /><meta property="og:site_name" content="305Sports" /><meta property="article:tag" content="Austin Jackson" /><meta property="article:tag" content="Austin Jackson Miami Dolphins" /><meta property="article:tag" content="Austin Jackson NFL Draft" /><meta property="article:tag" content="Dolphins" /><meta property="article:tag" content="featured" /><meta property="article:tag" content="Miami Dolphins" /><meta property="article:tag" content="Miami Dolphins NFL Draft" /><meta property="article:tag" content="NFL" /><meta property="article:tag" content="NFL Draft" /><meta property="article:tag" content="USC" /><meta property="article:section" content="Miami Dolphins" /><meta property="article:published_time" content="2020-04-24T02:44:56+00:00" /><meta property="article:modified_time" content="2020-04-24T02:54:11+00:00" /><meta property="og:updated_time" content="2020-04-24T02:54:11+00:00" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg" /><meta property="og:image:secure_url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg" /><meta property="og:image:width" content="1000" /><meta property="og:image:height" content="600" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The Miami Dolphins have selected former USC offensive tackle Austin Jackson with the 18th overall pick in the 2020 NFL Draft.&nbsp; Austin Jackson, (6-foot-4, 322 lbs) fills the Dolphins needs at the offensive-line position to protect Miami&#8217;s recent addition in quarterback Tua Tagovailoa. He has an aggressive play style in which he initiates contact with [&hellip;]" /><meta name="twitter:title" content="Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft - 305Sports" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg" /><meta name="twitter:creator" content="@MichaelYero" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.305sports.net/#website","url":"https://www.305sports.net/","name":"305Sports","inLanguage":"en-US","description":"Providing In-Depth Analysis And Coverage Of Miami Sports. ","potentialAction":[{"@type":"SearchAction","target":"https://www.305sports.net/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/#primaryimage","inLanguage":"en-US","url":"https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg","width":1000,"height":600},{"@type":"WebPage","@id":"https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/#webpage","url":"https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/","name":"Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft - 305Sports","isPartOf":{"@id":"https://www.305sports.net/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/#primaryimage"},"datePublished":"2020-04-24T02:44:56+00:00","dateModified":"2020-04-24T02:54:11+00:00","author":{"@id":"https://www.305sports.net/#/schema/person/a794839bf7e848ad00664956c5077b0a"},"potentialAction":[{"@type":"ReadAction","target":["https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/"]}]},{"@type":["Person"],"@id":"https://www.305sports.net/#/schema/person/a794839bf7e848ad00664956c5077b0a","name":"Michael Yero","image":{"@type":"ImageObject","@id":"https://www.305sports.net/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=96&d=mm&r=g","caption":"Michael Yero"},"description":"Miami Heat Writer for 305Sports. Michael is a die-hard Heat fan and a High-School Basketball player. Born and Raised in the 305.","sameAs":["https://www.instagram.com/michael.yero/","https://twitter.com/MichaelYero"]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Feed" href="https://www.305sports.net/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Comments Feed" href="https://www.305sports.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft Comments Feed" href="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.305sports.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style type="text/css">#wpadminbar #wp-admin-bar-my-networks > .ab-item:first-child:before {
                content: "\f325";
                top: 3px;
            }</style><style id='mvp-custom-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /> <script type='text/javascript' src='https://www.305sports.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-156579328-1' async></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-156579328-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.305sports.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.305sports.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.305sports.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4" /><link rel='shortlink' href='https://www.305sports.net/?p=6652' /><link rel="alternate" type="application/json+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#f890e7";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <meta name="generator" content="Site Kit by Google 1.6.0" /><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9318763060154915",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/cropped-305-Logo-32x32.jpg" sizes="32x32" /><link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/cropped-305-Logo-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/cropped-305-Logo-180x180.jpg" /><meta name="msapplication-TileImage" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/cropped-305-Logo-270x270.jpg" /> <script src="https://www.305sports.net/wp-content/cache/autoptimize/6/js/autoptimize_d8349ecb9dd7b9177d0b92a53f2991a6.js"></script></head><body class="post-template-default single single-post postid-6652 single-format-standard et_bloom"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1AD9D7BB-D42D-4065-A212-DA2B5A479D74.png" alt="305Sports" data-rjs="2" /></a></div><!--mvp-fly-logo--></div><!--mvp-fly-top-in--><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-fly-top-out--></div><!--mvp-fly-menu-top--><div id="mvp-fly-menu-wrap"><nav class="mvp-fly-nav-menu left relative"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li id="menu-item-361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li><li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li></ul></li><li id="menu-item-6263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li id="menu-item-100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-100"><a href="https://www.305sports.net/category/dade-sports/">Miami-Dade Sports</a><ul class="sub-menu"><li id="menu-item-98" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98"><a href="https://www.305sports.net/category/dade-b-ball/">Miami-Dade Basketball</a></li><li id="menu-item-99" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99"><a href="https://www.305sports.net/category/dade-fball/">Miami-Dade Football</a></li></ul></li><li id="menu-item-6265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6265"><a href="https://www.305sports.net/category/broward-county/">Broward County</a></li><li id="menu-item-6266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6266"><a href="https://www.305sports.net/category/palm-beach-county/">Palm Beach County</a></li></ul></li><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li id="menu-item-4263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li></ul></div></nav></div><!--mvp-fly-menu-wrap--><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://www.facebook.com/pg/305sportss" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li></ul></div><!--mvp-fly-soc-wrap--></div><!--mvp-fly-wrap--><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://www.305sports.net/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><!--mvp-search-box--><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div><!--mvp-search-but-wrap--></div><!--mvp-search-wrap--><header id="mvp-top-head-wrap"><nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-top-nav-menu-but--><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://www.305sports.net/"><img itemprop="logo" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1AD9D7BB-D42D-4065-A212-DA2B5A479D74.png" alt="305Sports" data-rjs="2" /></a><h2 class="mvp-logo-title">305Sports</h2></div><!--mvp-top-nav-logo--></div><!--mvp-top-nav-left-in--></div><!--mvp-top-nav-left-out--></div><!--mvp-top-nav-left--></div><!--mvp-top-nav-right-in--><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.instagram.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/305Sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://www.facebook.com/pg/305sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div><!--mvp-top-nav-soc--> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div><!--mvp-top-nav-right--></div><!--mvp-top-nav-right-out--></div><!--mvp-top-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-top-nav-wrap--><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-primary-container"><ul id="menu-primary-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-100"><a href="https://www.305sports.net/category/dade-sports/">Miami-Dade Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98"><a href="https://www.305sports.net/category/dade-b-ball/">Miami-Dade Basketball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99"><a href="https://www.305sports.net/category/dade-fball/">Miami-Dade Football</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6265"><a href="https://www.305sports.net/category/broward-county/">Broward County</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6266"><a href="https://www.305sports.net/category/palm-beach-county/">Palm Beach County</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li></ul></div></div><!--mvp-nav-menu--></div><!--mvp-bot-nav-in--></div><!--mvp-bot-nav-out--></div><!--mvp-bot-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-bot-nav-wrap--></nav><!--mvp-main-nav-wrap--></header><main id="mvp-main-wrap" class="left relative"><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-6652 post type-post status-publish format-standard has-post-thumbnail hentry category-miami-dolphins tag-austin-jackson tag-austin-jackson-miami-dolphins tag-austin-jackson-nfl-draft tag-dolphins tag-featured tag-miami-dolphins tag-miami-dolphins-nfl-draft tag-nfl tag-nfl-draft tag-usc" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/"/><div id="mvp-article-head" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.305sports.net/category/miami-dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft</h1><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bf0ced4e90c25b496480e055c1a834ab?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.305sports.net/author/michaelyero/" title="Posts by Michael Yero" rel="author">Michael Yero</a></span></li><li class="mvp-author-info-twit"> <a href="MichaelYero" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-04-24">April 24, 2020</time></span><meta itemprop="dateModified" content="2020-04-24"/></li></ul></div><!--mvp-author-info-wrap--></div><!--mvp-article-head--><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/&amp;t=Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft -&amp;url=https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg&amp;description=Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#f8c78b8d9a929d9b8cc5b591999591d8bc9794889091968bd8ac99939dd8b98d8b8c9196d8b2999b938b9796d8af918c90d8a8919b93d8b697d6d8c9c0d8b196d8b6beb4d8bc8a999e8cde999588c3bab7bca1c5b1d89e978d969cd88c90918bd8998a8c919b949dd891968c9d8a9d8b8c91969fd899969cd88c90978d9f908cd8979ed88b90998a91969fd8918cd88f918c90d881978dd6d8bb909d9b93d8918cd8978d8cc2d8908c8c888bc2d7d78f8f8fd6cbc8cd8b88978a8c8bd6969d8cd79591999591d59c9794889091968bd58c99939dd5998d8b8c9196d592999b938b9796d58f918c90d588919b93d59697d5c9c0d59196d5969e94d59c8a999e8cd7"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/#respond"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="1000" height="600" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg 1000w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson-300x180.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson-768x461.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson-610x366.jpg 610w" sizes="(max-width: 1000px) 100vw, 1000px" /><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="600"></div><!--mvp-post-feat-img--> <span class="mvp-feat-caption">Mark J. Rebilas-USA TODAY Sports</span><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/" data-a2a-title="Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p>The Miami Dolphins have selected former USC offensive tackle Austin Jackson with the 18th overall pick in the 2020 NFL Draft.&nbsp;</p><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B_WOSZ3l1w6/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B_WOSZ3l1w6/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B_WOSZ3l1w6/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Welcome #AustinJackson to the #MiamiDolphins . #FinsUp 🐬</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/305sportss/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> 305 Sports 🧠</a> (@305sportss) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-04-24T02:42:13+00:00">Apr 23, 2020 at 7:42pm PDT</time></p></div></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//www.instagram.com/embed.js"></script> </div></figure><p>Austin Jackson, (6-foot-4, 322 lbs) fills the Dolphins needs at the offensive-line position to protect Miami&#8217;s recent addition in quarterback Tua Tagovailoa. He has an aggressive play style in which he initiates contact with defenders to climb to the next level. Jackson&#8217;s length, mobility, and quickness will make him very capable of becoming a starter at the second level.</p><p>Jackson served as USC’s anchor along the offensive line. His impressive performances were well noticed, earning the two-year starter first-team All-Pac 12 Honors. He started all 13 games at left tackle in 2019.</p><p>Although Jackson was projected to be a Day 2 prospect, with offensive tackles Andrew Thomas, Jedrick Wills Jr, Mekhi Becton, and Tristan Wirfs off the board, Miami decided to take the best available offensive lineman before anyone else could.</p><figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"> <iframe title="Austin Jackson Highlights| NFL Draft 2020" width="1000" height="563" src="https://www.youtube.com/embed/aO2EjdkCvus?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></figure><p>&#8220;Early-entry tackle prospect who is raw but gifted and is likely to be coveted by a variety of teams, thanks to his true left tackle traits.&#8221; Said NFL.com&#8217;s Lance Zierlein on the USC offensive lineman. &#8220;Jackson has loads of athletic ability and play talent that is waiting to be developed and harvested.&#8221;</p><p> &#8220;Inconsistent hand placement and footwork could be exploited early on if teams try and rush him into the starting lineup, but issues are correctable. He&#8217;s scheme-diverse with potential guard flexibility if he improves his strength. He could become an early starter but may offer a wider split between floor and ceiling than some teams might like.&#8221;</p><p>The Dolphins aren&#8217;t done tonight, they will next be on the clock with the 26th pick, acquiring the selection in the trade that sent offensive tackle Laremy Tunsil and wide receiver Kenny Stills to the Houston Texans.</p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/" data-a2a-title="Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fmiami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft%2F&amp;linkname=Miami%20Dolphins%20Take%20Austin%20Jackson%20With%20Pick%20No.%2018%20In%20NFL%20Draft" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.305sports.net/tag/austin-jackson/" rel="tag">Austin Jackson</a><a href="https://www.305sports.net/tag/austin-jackson-miami-dolphins/" rel="tag">Austin Jackson Miami Dolphins</a><a href="https://www.305sports.net/tag/austin-jackson-nfl-draft/" rel="tag">Austin Jackson NFL Draft</a><a href="https://www.305sports.net/tag/dolphins/" rel="tag">Dolphins</a><a href="https://www.305sports.net/tag/featured/" rel="tag">featured</a><a href="https://www.305sports.net/tag/miami-dolphins/" rel="tag">Miami Dolphins</a><a href="https://www.305sports.net/tag/miami-dolphins-nfl-draft/" rel="tag">Miami Dolphins NFL Draft</a><a href="https://www.305sports.net/tag/nfl/" rel="tag">NFL</a><a href="https://www.305sports.net/tag/nfl-draft/" rel="tag">NFL Draft</a><a href="https://www.305sports.net/tag/usc/" rel="tag">USC</a></span></div><!--mvp-post-tags--><div class="posts-nav-link"></div><!--posts-nav-link--><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1AD9D7BB-D42D-4065-A212-DA2B5A479D74.png"/><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1AD9D7BB-D42D-4065-A212-DA2B5A479D74.png"></div><!--mvp-org-logo--><meta itemprop="name" content="305Sports"></div><!--mvp-org-wrap--></div><!--mvp-content-main--><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text">Click to comment</span></div><!--mvp-comments-button--><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.305sports.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p><p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='6652' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!--comments--></div><!--mvp-post-soc-in--></div><!--mvp-post-soc-out--></div><!--mvp-content-box--></div><!--mvp-post-content--></div><!--mvp-post-content-in--><div id="mvp-side-wrap" class="relative"></div><!--mvp-side-wrap--></div><!--mvp-post-content-out--><section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Miami Dolphins</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://www.305sports.net/breaking-dolphins-trade-pick-no-26-to-packers-for-picks-no-30-136/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1181710839.jpg.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1181710839.jpg.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1181710839.jpg.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1181710839.jpg.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1181710839.jpg.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1181710839.jpg.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/breaking-dolphins-trade-pick-no-26-to-packers-for-picks-no-30-136/" rel="bookmark">BREAKING: Dolphins Trade Pick No. 26 To Packers For Picks No. 30 And 136</a></h2><p>The Miami Dolphins have traded pick No. 30 to the Green Bay Packers in...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/miami-dolphins-pick-tua-tagovailoa-with-no-5-in-nfl-draft/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/960x0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/960x0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/960x0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/960x0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/miami-dolphins-pick-tua-tagovailoa-with-no-5-in-nfl-draft/" rel="bookmark">Miami Dolphins Take Tua Tagovailoa With Pick No. 5 In NFL Draft</a></h2><p>At last, we have our answer. The Miami Dolphins selected Alabama’s Tua Tagovailoa as...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/dolphins-news-4-22-20-miami-looking-to-acquire-no-3-pick-in-draft-want-to-keep-pick-no-5/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/dolphins-news-4-22-20-miami-looking-to-acquire-no-3-pick-in-draft-want-to-keep-pick-no-5/" rel="bookmark">Dolphins News 4/22/20: Miami Looking To Acquire No. 3 Pick In Draft; Want To Keep Pick No. 5</a></h2><p>Miami looking to acquire the No. 3 pick According to Miami Herald’s Barry Jackson,...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/who-the-dolphins-have-had-pre-draft-workouts-visits-with/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/XZ2BRQL46BBUVNZBZ6YMLZYHPY-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/XZ2BRQL46BBUVNZBZ6YMLZYHPY-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/XZ2BRQL46BBUVNZBZ6YMLZYHPY-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/XZ2BRQL46BBUVNZBZ6YMLZYHPY-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/XZ2BRQL46BBUVNZBZ6YMLZYHPY-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/XZ2BRQL46BBUVNZBZ6YMLZYHPY-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/who-the-dolphins-have-had-pre-draft-workouts-visits-with/" rel="bookmark">Who The Dolphins Have Had Pre-Draft Workouts/Visits With</a></h2><p>Unlike the usual, Chris Grier and the Miami Dolphins have had to find creative...</p></div><!--mvp-more-post-text--></li></ul></section><!--mvp-more-post-wrap--><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/miami-dolphins-pick-tua-tagovailoa-with-no-5-in-nfl-draft/" rel="prev">Miami Dolphins Take Tua Tagovailoa With Pick No. 5 In NFL Draft</a></div><!--mvp-prev-post-text--></div><!--mvp-prev-post-wrap--><div id="mvp-next-post-wrap"><div id="mvp-next-post-arrow" class="relative"> <span class="fa fa-angle-right fa-4 " aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/breaking-dolphins-trade-pick-no-26-to-packers-for-picks-no-30-136/" rel="next">BREAKING: Dolphins Trade Pick No. 26 To Packers For Picks No. 30 And 136</a></div><!--mvp-prev-next-text--></div><!--mvp-next-post-wrap--></div><!--mvp-prev-next-wrap--></div><!--mvp-sec-pad--></article><!--mvp-article-wrap--></div><!--mvp-main-body--></div><!--mvp-main-box-cont--></div><!--mvp-main-body-wrap--></main><!--mvp-main-wrap--><footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="" alt="305Sports" data-rjs="2" /></a></div><!--mvp-foot-logo--><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://www.facebook.com/pg/305sportss" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li></ul></div><!--mvp-foot-soc--></div><!--mvp-main-box-cont--></div><!--mvp-foot-top--><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"></div><!--mvp-foot-menu--></div><!--mvp-main-box-cont--></div><!--mvp-foot-menu-wrap--><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>Copyright © 2020 305Sports</p></div><!--mvp-foot-copy--></div><!--mvp-main-box-cont--></div><!--mvp-foot-copy-wrap--></div><!--mvp-foot-bot--></footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/&amp;t=Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft -&amp;url=https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/miami-dolphins-take-austin-jackson-with-pick-no-18-in-nfl-draft/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/04/jackson.jpg&amp;description=Miami Dolphins Take Austin Jackson With Pick No. 18 In NFL Draft', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#b58ac6c0d7dfd0d6c188f8dcd4d8dc95f1dad9c5dddcdbc695e1d4ded095f4c0c6c1dcdb95ffd4d6dec6dadb95e2dcc1dd95e5dcd6de95fbda9b95848d95fcdb95fbf3f995f1c7d4d3c193d4d8c58ef7faf1ec88fc95d3dac0dbd195c1dddcc695d4c7c1dcd6d9d095dcdbc1d0c7d0c6c1dcdbd295d4dbd195c1dddac0d2ddc195dad395c6ddd4c7dcdbd295dcc195c2dcc1dd95ccdac09b95f6ddd0d6de95dcc195dac0c18f95ddc1c1c5c68f9a9ac2c2c29b868580c6c5dac7c1c69bdbd0c19ad8dcd4d8dc98d1dad9c5dddcdbc698c1d4ded098d4c0c6c1dcdb98dfd4d6dec6dadb98c2dcc1dd98c5dcd6de98dbda98848d98dcdb98dbd3d998d1c7d4d3c19a"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--></div><!--mvp-site--><div id="mvp-post-trend-wrap"><div class="mvp-main-box-cont relative"><ul class="mvp-post-trend-list left relative"><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/dolphins-news-4-20-20-miami-interested-in-trading-up-from-pick-18/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/usa_today_13736415.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/usa_today_13736415.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/usa_today_13736415.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/dolphins-news-4-20-20-miami-interested-in-trading-up-from-pick-18/" rel="bookmark">Dolphins News 4/20/20: Miami Interested In Trading Up From Pick 18</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/the-history-of-having-3-first-round-picks/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/fgnsbdzagn4jxyxcl3i7-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/fgnsbdzagn4jxyxcl3i7-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/fgnsbdzagn4jxyxcl3i7-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/the-history-of-having-3-first-round-picks/" rel="bookmark">The History of Having 3 First Round Picks</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/dolphins-news-4-22-20-miami-looking-to-acquire-no-3-pick-in-draft-want-to-keep-pick-no-5/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/1143782315.jpg.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/dolphins-news-4-22-20-miami-looking-to-acquire-no-3-pick-in-draft-want-to-keep-pick-no-5/" rel="bookmark">Dolphins News 4/22/20: Miami Looking To Acquire No. 3 Pick In Draft; Want To Keep Pick No. 5</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/305-talks-predicting-all-of-miamis-14-picks/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/JH2-640x360-1-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/04/JH2-640x360-1-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/04/JH2-640x360-1-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/305-talks-predicting-all-of-miamis-14-picks/" rel="bookmark">305 Talks &#8211; Predicting All Of Miami&#8217;s First And Second Round Picks</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li></ul> <span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span></div><!--mvp-main-box-cont--></div><!--mvp-post-trend-wrap--><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><!--mvp-fly-top--><div class="mvp-fly-fade mvp-fly-but-click"></div><!--mvp-fly-fade--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script> </body></html>