<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://www.305sports.net/xmlrpc.php" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-1000x600.jpg" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-1000x600.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="It&#8217;s not hidden that Miami&#8217;s running game has picked up in December. With the duo of former Washington Husky&#8217;s Myles Gaskin and Salvon Ahmed leading the charge and Matt Breida also getting his fair share of representation, the Dolphins have finally proven that they can run the ball if needed. Ending a streak With Miami [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/"><meta name="twitter:title" content="How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks"><meta name="twitter:description" content="It&#8217;s not hidden that Miami&#8217;s running game has picked up in December. With the duo of former Washington Husky&#8217;s Myles Gaskin and Salvon Ahmed leading the charge and Matt Breida also getting his fair share of representation, the Dolphins have finally proven that they can run the ball if needed. Ending a streak With Miami [&hellip;]"> <script>var et_site_url='https://www.305sports.net';var et_post_id='26233';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script> <!-- This site is optimized with the Yoast SEO plugin v14.8 - https://yoast.com/wordpress/plugins/seo/ --><style media="all">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</style><title>How Miami&#039;s Running Game Has Gone From Zero To Hero In Two Weeks - 305Sports</title><meta name="description" content="Teammates since their collegiate days, Myles Gaskin and Salvon Ahmed are reviving Miami&#039;s running game, and it&#039;s producing victories." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How Miami&#039;s Running Game Has Gone From Zero To Hero In Two Weeks - 305Sports" /><meta property="og:description" content="Teammates since their collegiate days, Myles Gaskin and Salvon Ahmed are reviving Miami&#039;s running game, and it&#039;s producing victories." /><meta property="og:url" content="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/" /><meta property="og:site_name" content="305Sports" /><meta property="article:published_time" content="2021-01-03T15:57:43+00:00" /><meta property="article:modified_time" content="2021-01-03T16:47:12+00:00" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="800" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@www.twitter.com/GabeGlassman" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.305sports.net/#website","url":"https://www.305sports.net/","name":"305Sports","description":"Providing In-Depth Analysis And Coverage Of Miami Sports.","potentialAction":[{"@type":"SearchAction","target":"https://www.305sports.net/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/#primaryimage","inLanguage":"en-US","url":"https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0.jpg","width":1200,"height":800},{"@type":"WebPage","@id":"https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/#webpage","url":"https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/","name":"How Miami's Running Game Has Gone From Zero To Hero In Two Weeks - 305Sports","isPartOf":{"@id":"https://www.305sports.net/#website"},"primaryImageOfPage":{"@id":"https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/#primaryimage"},"datePublished":"2021-01-03T15:57:43+00:00","dateModified":"2021-01-03T16:47:12+00:00","author":{"@id":"https://www.305sports.net/#/schema/person/b59e1f12c5e790a2fec987771626d31b"},"description":"Teammates since their collegiate days, Myles Gaskin and Salvon Ahmed are reviving Miami's running game, and it's producing victories.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/"]}]},{"@type":"Person","@id":"https://www.305sports.net/#/schema/person/b59e1f12c5e790a2fec987771626d31b","name":"Gabe Glassman","image":{"@type":"ImageObject","@id":"https://www.305sports.net/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=96&d=mm&r=g","caption":"Gabe Glassman"},"description":"Gabe Glassman is an experienced sports broadcaster, having won 5 awards in state-wide and national competitions in the last two years. Gabe spent the last 4 years at Marjory Stoneman Douglas High School with 3 of those years being the Sports Director for WMSD-TV. He has been a South Florida sports fan all of his life. Glassman is currently attending the University of South Florida as a Mass Communications Major. Gabe is excited to get the opportunity to work with the 305 Sports Crew and to write about his favorite sports!","sameAs":["www.instagram.com/officialgabeglassman","https://twitter.com/www.twitter.com/GabeGlassman","www.youtube.com/GabeGlassman"]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Feed" href="https://www.305sports.net/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Comments Feed" href="https://www.305sports.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks Comments Feed" href="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.305sports.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style type="text/css">#wpadminbar #wp-admin-bar-my-networks > .ab-item:first-child:before {
                content: "\f325";
                top: 3px;
            }</style><style id='mvp-custom-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /> <script type='text/javascript' src='https://www.305sports.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-156579328-1'></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-156579328-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.305sports.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.305sports.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.305sports.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.4" /><link rel='shortlink' href='https://www.305sports.net/?p=26233' /><link rel="alternate" type="application/json+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#f890e7";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <meta name="generator" content="Site Kit by Google 1.14.0" /><script data-ad-client="ca-pub-9318763060154915" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- VINTCER_DO_NOT_REMOVE --> <script type="text/javascript">var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.www.305sports.net"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//vint-analytics.vintcer.io/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '5']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();</script> <!-- VINTCER_DO_NOT_REMOVE --><meta property="fb:app_id" content=""><meta property="fb:admins" content=""><div id="fb-root"></div> <script>(function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id))
                        return;
                    js = d.createElement(s);
                    js.id = id;
                    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
                    fjs.parentNode.insertBefore(js, fjs);
                }(document, 'script', 'facebook-jssdk'));</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9318763060154915",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-180x180.png" /><meta name="msapplication-TileImage" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-270x270.png" /> <script src="https://www.305sports.net/wp-content/cache/autoptimize/6/js/autoptimize_d01ef3aa366168ff6e08c3faf50e1dfa.js"></script></head><body class="post-template-default single single-post postid-26233 single-format-standard et_bloom"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a></div><!--mvp-fly-logo--></div><!--mvp-fly-top-in--><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-fly-top-out--></div><!--mvp-fly-menu-top--><div id="mvp-fly-menu-wrap"><nav class="mvp-fly-nav-menu left relative"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li id="menu-item-6263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li id="menu-item-12213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li id="menu-item-12212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li id="menu-item-9011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li id="menu-item-4263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li id="menu-item-8714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li id="menu-item-8951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li id="menu-item-8952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li id="menu-item-8953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU Panthers</a></li></ul></li></ul></div></nav></div><!--mvp-fly-menu-wrap--><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-fly-soc-wrap--></div><!--mvp-fly-wrap--><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://www.305sports.net/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><!--mvp-search-box--><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div><!--mvp-search-but-wrap--></div><!--mvp-search-wrap--><header id="mvp-top-head-wrap"><nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-top-nav-menu-but--><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://www.305sports.net/"><img itemprop="logo" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a><h2 class="mvp-logo-title">305Sports</h2></div><!--mvp-top-nav-logo--></div><!--mvp-top-nav-left-in--></div><!--mvp-top-nav-left-out--></div><!--mvp-top-nav-left--></div><!--mvp-top-nav-right-in--><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="https://www.instagram.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/305Sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://www.facebook.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div><!--mvp-top-nav-soc--> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div><!--mvp-top-nav-right--></div><!--mvp-top-nav-right-out--></div><!--mvp-top-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-top-nav-wrap--><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-primary-container"><ul id="menu-primary-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU Panthers</a></li></ul></li></ul></div></div><!--mvp-nav-menu--></div><!--mvp-bot-nav-in--></div><!--mvp-bot-nav-out--></div><!--mvp-bot-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-bot-nav-wrap--></nav><!--mvp-main-nav-wrap--></header><main id="mvp-main-wrap" class="left relative"><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-26233 post type-post status-publish format-standard has-post-thumbnail hentry category-miami-dolphins tag-featured tag-miami-dolphins tag-myles-gaskin tag-salvon-ahmed" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/"/><div id="mvp-article-head" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.305sports.net/category/miami-dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks</h1><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.305sports.net/author/gabeglassman/" title="Posts by Gabe Glassman" rel="author">Gabe Glassman</a></span></li><li class="mvp-author-info-twit"> <a href="www.twitter.com/GabeGlassman" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2021-01-03">January 3, 2021</time></span><meta itemprop="dateModified" content="2021-01-03"/></li></ul></div><!--mvp-author-info-wrap--></div><!--mvp-article-head--><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/&amp;t=How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks -&amp;url=https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-1000x600.jpg&amp;description=How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#56692523343c3335226b1e3921761b3f373b3f70756e6467616d2576042338383f38317611373b33761e37257611393833761024393b760c332439760239761e332439761f3876022139760133333d2570373b266d1419120f6b1f76303923383276223e3f25763724223f353a33763f382233243325223f38317637383276223e3923313e2276393076253e37243f3831763f2276213f223e762f39237876153e33353d763f22763923226c763e222226256c79792121217865666325263924222578383322793e39217b3b3f373b3f257b242338383f38317b31373b337b3e37257b313938337b3024393b7b2c3324397b22397b3e3324397b3f387b2221397b2133333d2579"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/#respond"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="1200" height="800" src="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0.jpg 1200w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-300x200.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-1024x683.jpg 1024w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-768x512.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-610x407.jpg 610w" sizes="(max-width: 1200px) 100vw, 1200px" /><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-1000x600.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="600"></div><!--mvp-post-feat-img--> <span class="mvp-feat-caption">Photo by Harry How/Getty Images</span><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/" data-a2a-title="How Miami’s Running Game Has Gone From Zero To Hero In Two Weeks"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><style>.fb_iframe_widget span{width:460px !important;} .fb_iframe_widget iframe {margin: 0 !important;}        .fb_edge_comment_widget { display: none !important; }</style><div style="width:100%; text-align:left"><div class="fb-like" style="width:450px; overflow: hidden !important; " data-href="https://www.facebook.com/305sportss/" data-size="small" data-colorscheme="light" data-width="450" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false" kid_directed_site="false"></div></div><p>It&#8217;s not hidden that <a href="https://www.305sports.net/category/miami-dolphins/">Miami&#8217;s</a> running game has picked up in December. With the duo of former Washington Husky&#8217;s Myles Gaskin and Salvon Ahmed leading the charge and Matt Breida also getting his fair share of representation, the Dolphins have finally proven that they can run the ball if needed.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Matt Breida&#39;s burst of speed 😳 <a href="https://twitter.com/MattBreida?ref_src=twsrc%5Etfw">@MattBreida</a> <a href="https://twitter.com/MiamiDolphins?ref_src=twsrc%5Etfw">@MiamiDolphins</a> <br><br>📺 <a href="https://twitter.com/hashtag/NEvsMIA?src=hash&amp;ref_src=twsrc%5Etfw">#NEvsMIA</a> on CBS <a href="https://t.co/Fp7AWk3e3z">pic.twitter.com/Fp7AWk3e3z</a></p>&mdash; The Checkdown (@thecheckdown) <a href="https://twitter.com/thecheckdown/status/1340758969015406592?ref_src=twsrc%5Etfw">December 20, 2020</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h4><strong>Ending a streak</strong></h4><p>With Miami down their top three receivers and top rusher, it was evident that the Dolphins needed a stronger run game than ever to defeat the New England Patriots in a Week 15 rivalry battle. Ahmed gave what all fans asked for: a 100-yard rushing game. For the first time in 31 games, Miami had a tailback rush in the triple-digits. Ahmed finished with 122 yards on 23 very strong carries. His running mate Breida wasn&#8217;t too far behind him, rushing for 86 yards on 12 attempts. Miami&#8217;s 250+ rushing yards would end up earning themselves an important win in December with a final score of 22-12.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Second effort from Salvon Ahmed and the <a href="https://twitter.com/MiamiDolphins?ref_src=twsrc%5Etfw">@MiamiDolphins</a> take the lead! <a href="https://twitter.com/hashtag/FinsUp?src=hash&amp;ref_src=twsrc%5Etfw">#FinsUp</a> <br><br>📺: <a href="https://twitter.com/hashtag/NEvsMIA?src=hash&amp;ref_src=twsrc%5Etfw">#NEvsMIA</a> on CBS<br>📱: NFL app // Yahoo Sports app: <a href="https://t.co/EJLjYXQNy2">https://t.co/EJLjYXQNy2</a> <a href="https://t.co/9kozWJcIvQ">pic.twitter.com/9kozWJcIvQ</a></p>&mdash; NFL (@NFL) <a href="https://twitter.com/NFL/status/1340743873702682624?ref_src=twsrc%5Etfw">December 20, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h4><strong>Continuing the excellence </strong></h4><p>Six days after Salvon Ahmed and Matt Breida&#8217;s strong holding in the backfield, the Dolphins gained their top RB Gaskin back on the roster from the COVID-19 list. After being out for two games, Gaskin came back and continued to show off his skill. He ran for 87 yards on 14 carries, which included one TD. Gaskin would also show fans around the world his skills as a receiver, having 82 receiving yards on five catches, which also included his massive 57-yard TD which gave Miami the lead at one point in the game vs. the Las Vegas Raiders.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Myles Gaskin gets it RIGHT BACK.<br><br>Dolphins lead.<br><br>(via <a href="https://twitter.com/NFL?ref_src=twsrc%5Etfw">@NFL</a>)<a href="https://t.co/JUx92b6jq3">pic.twitter.com/JUx92b6jq3</a></p>&mdash; SportsCenter (@SportsCenter) <a href="https://twitter.com/SportsCenter/status/1343044903203442688?ref_src=twsrc%5Etfw">December 27, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h4><strong>The history of the Husky duo</strong></h4><p>Gaskin and Ahmed were teammates at Washington University in the 2017 and 2018 seasons. Gaskin was RB1 for the Huskies since his freshman year in 2015 and Ahmed continued his legacy after he left in 2019. Gaskin achieved PAC-12 legend status during his time in college, totaling over <a href="https://www.sports-reference.com/cfb/players/myles-gaskin-1.html">5,320 rushing yards and 57 touchdowns</a>, making him Washington&#8217;s all-time leading rusher and rushing TD scorer.</p><p>Myles&#8217; history in college also put him at No. 3 for most rushing yards and No. 6 for most TDs in PAC-12 history. Although Ahmed isn&#8217;t on as many leaderboards as his forever teammate, don&#8217;t let that pull you away from his 2,016 rushing yards and 21 TDs within three years played in college.</p><figure class="wp-block-image size-large"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original-1024x658.jpg" alt="Myles Gaskin" class="wp-image-26254" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original-1024x658.jpg 1024w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original-300x193.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original-768x493.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original-1536x987.jpg 1536w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original-610x392.jpg 610w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/4081-63941-original.jpg 1560w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Myles Gaskin and Salvon Ahmed were teammates at Washington. <em>(Dean Rutz / The Seattle Times)</em></figcaption></figure><p>Where did the Dolphins get these two scary dudes? Miami picked up Gaskin as a 7th round steal in the 2019 NFL Draft, keeping him on the sidelines for most of the season, backing up Kenyan Drake, Kalen Ballage and Patrick Laird. As for Ahmed, he originally signed as a free agent with the San Francisco 49ers almost immediately after the 2020 NFL Draft. Later on, Ahmed would be waived and claimed by the Dolphins in August a few weeks before the 2020 season was set to kick off.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Have a night, Myles Gaskin. <br><br>As in a career-high 202 rushing yards in Washington&#39;s rout of Colorado. <a href="https://t.co/j0pFJhP7OR">pic.twitter.com/j0pFJhP7OR</a></p>&mdash; ESPN (@espn) <a href="https://twitter.com/espn/status/911823083153104898?ref_src=twsrc%5Etfw">September 24, 2017</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p>Coming up on the most important game for Gaskin&#8217; and Ahmed&#8217; careers, Miami&#8217;s run game needs to be stronger than it ever has before for the Dolphins to clinch a postseason berth. Even if Miami wins on Sunday against the scary-looking Buffalo Bills, their strong running attack would have to continue for however long their playoff campaign lasts and in seasons to come.</p><p>Dolphins fans have been waiting for great performances from their running backs ever since the Ricky Williams and Ronnie Brown era. Now with Gaskin and Ahmed, Dolphins fans could just be in luck to be witnessing some legendary rushing between the former Washington Husky legends.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Myles Gaskin will NOT be denied. <a href="https://twitter.com/MylesGAS?ref_src=twsrc%5Etfw">@MylesGAS</a> <a href="https://twitter.com/hashtag/FinsUp?src=hash&amp;ref_src=twsrc%5Etfw">#FinsUp</a><br><br>📺: <a href="https://twitter.com/hashtag/MIAvsLV?src=hash&amp;ref_src=twsrc%5Etfw">#MIAvsLV</a> on <a href="https://twitter.com/nflnetwork?ref_src=twsrc%5Etfw">@NFLNetwork</a><br>📱: NFL app // Yahoo Sports app: <a href="https://t.co/Gd3pMdskDl">https://t.co/Gd3pMdskDl</a> <a href="https://t.co/4VvDoWCnH5">pic.twitter.com/4VvDoWCnH5</a></p>&mdash; NFL (@NFL) <a href="https://twitter.com/NFL/status/1343028967935078400?ref_src=twsrc%5Etfw">December 27, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/" data-a2a-title="How Miami’s Running Game Has Gone From Zero To Hero In Two Weeks"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fhow-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks%2F&amp;linkname=How%20Miami%E2%80%99s%20Running%20Game%20Has%20Gone%20From%20Zero%20To%20Hero%20In%20Two%20Weeks" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.305sports.net/tag/featured/" rel="tag">featured</a><a href="https://www.305sports.net/tag/miami-dolphins/" rel="tag">Miami Dolphins</a><a href="https://www.305sports.net/tag/myles-gaskin/" rel="tag">Myles Gaskin</a><a href="https://www.305sports.net/tag/salvon-ahmed/" rel="tag">Salvon Ahmed</a></span></div><!--mvp-post-tags--><div class="posts-nav-link"></div><!--posts-nav-link--><div id="mvp-author-box-wrap" class="left relative"><div class="mvp-author-box-out right relative"><div id="mvp-author-box-img" class="left relative"> <img alt='' src='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></div><!--mvp-author-box-img--><div class="mvp-author-box-in"><div id="mvp-author-box-head" class="left relative"> <span class="mvp-author-box-name left relative"><a href="https://www.305sports.net/author/gabeglassman/" title="Posts by Gabe Glassman" rel="author">Gabe Glassman</a></span><div id="mvp-author-box-soc-wrap" class="left relative"> <a href="www.twitter.com/GabeGlassman" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a> <a href="www.instagram.com/officialgabeglassman" alt="Instagram" target="_blank"><span class="mvp-author-box-soc fa fa-instagram fa-2"></span></a></div><!--mvp-author-box-soc-wrap--></div><!--mvp-author-box-head--></div><!--mvp-author-box-in--></div><!--mvp-author-box-out--><div id="mvp-author-box-text" class="left relative"><p>Gabe Glassman is an experienced sports broadcaster, having won 5 awards in state-wide and national competitions in the last two years. Gabe spent the last 4 years at Marjory Stoneman Douglas High School with 3 of those years being the Sports Director for WMSD-TV. He has been a South Florida sports fan all of his life. Glassman is currently attending the University of South Florida as a Mass Communications Major. Gabe is excited to get the opportunity to work with the 305 Sports Crew and to write about his favorite sports!</p></div><!--mvp-author-box-text--></div><!--mvp-author-box-wrap--><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"/><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"></div><!--mvp-org-logo--><meta itemprop="name" content="305Sports"></div><!--mvp-org-wrap--></div><!--mvp-content-main--><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text">Click to comment</span></div><!--mvp-comments-button--><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.305sports.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p><p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='26233' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!--comments--></div><!--mvp-post-soc-in--></div><!--mvp-post-soc-out--></div><!--mvp-content-box--></div><!--mvp-post-content--></div><!--mvp-post-content-in--><div id="mvp-side-wrap" class="relative"></div><!--mvp-side-wrap--></div><!--mvp-post-content-out--><section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Miami Dolphins</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://www.305sports.net/brian-flores-the-real-mvp-of-2020/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-300x180.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-768x461.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-610x366.jpg 610w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/brian-flores-the-real-mvp-of-2020/" rel="bookmark">Brian Flores: The Real MVP Of 2020</a></h2><p>Brian Flores doesn’t care what you or I think about his coaching decisions. He...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/afc-east-rundown-week-16/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/USATSI_15363715-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/USATSI_15363715-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/USATSI_15363715-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/USATSI_15363715-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/USATSI_15363715-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/USATSI_15363715-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/afc-east-rundown-week-16/" rel="bookmark">AFC East Rundown &#8211; Week 16</a></h2><p>This weekend in the AFC East started with a wild Saturday night in Las...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/fitzpatrick-delivers-but-tua-remains-under-center-right-or-wrong-move/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/fitzpatrick-delivers-but-tua-remains-under-center-right-or-wrong-move/" rel="bookmark">Fitzpatrick Delivers, But Tua Remains Under Center: Right Or Wrong Move?</a></h2><p>Miami QB Tua Tagovailoa and offensive coordinator Chan Gailey need some relationship therapy. With...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/miracle-on-the-strip-takeaways-from-miamis-win-in-vegas/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/np_file_60009-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/np_file_60009-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/np_file_60009-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/np_file_60009-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/np_file_60009-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/np_file_60009-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/miracle-on-the-strip-takeaways-from-miamis-win-in-vegas/" rel="bookmark">Miracle On The Strip: Takeaways From Miami&#8217;s Win In Vegas:</a></h2><p>Here are five takeaways from the Miami Dolphins&#8217; (10-5) 26-25 last-second victory over the...</p></div><!--mvp-more-post-text--></li></ul></section><!--mvp-more-post-wrap--><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/brian-flores-the-real-mvp-of-2020/" rel="prev">Brian Flores: The Real MVP Of 2020</a></div><!--mvp-prev-post-text--></div><!--mvp-prev-post-wrap--></div><!--mvp-prev-next-wrap--></div><!--mvp-sec-pad--></article><!--mvp-article-wrap--></div><!--mvp-main-body--></div><!--mvp-main-box-cont--></div><!--mvp-main-body-wrap--></main><!--mvp-main-wrap--><footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="" alt="305Sports" data-rjs="2" /></a></div><!--mvp-foot-logo--><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-foot-soc--></div><!--mvp-main-box-cont--></div><!--mvp-foot-top--><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"></div><!--mvp-foot-menu--></div><!--mvp-main-box-cont--></div><!--mvp-foot-menu-wrap--><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>305 SPORTS ENTERPRISES, INC.</p></div><!--mvp-foot-copy--></div><!--mvp-main-box-cont--></div><!--mvp-foot-copy-wrap--></div><!--mvp-foot-bot--></footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/&amp;t=How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks -&amp;url=https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-1000x600.jpg&amp;description=How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#d0efa3a5b2bab5b3a4ed98bfa7f09db9b1bdb9f6f3e8e2e1e7eba3f082a5bebeb9beb7f097b1bdb5f098b1a3f097bfbeb5f096a2bfbdf08ab5a2bff084bff098b5a2bff099bef084a7bff087b5b5bba3f6b1bda0eb929f9489ed99f0b6bfa5beb4f0a4b8b9a3f0b1a2a4b9b3bcb5f0b9bea4b5a2b5a3a4b9beb7f0b1beb4f0a4b8bfa5b7b8a4f0bfb6f0a3b8b1a2b9beb7f0b9a4f0a7b9a4b8f0a9bfa5fef093b8b5b3bbf0b9a4f0bfa5a4eaf0b8a4a4a0a3eaffffa7a7a7fee3e0e5a3a0bfa2a4a3febeb5a4ffb8bfa7fdbdb9b1bdb9a3fda2a5bebeb9beb7fdb7b1bdb5fdb8b1a3fdb7bfbeb5fdb6a2bfbdfdaab5a2bffda4bffdb8b5a2bffdb9befda4a7bffda7b5b5bba3ff"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--></div><!--mvp-site--><div id="mvp-post-trend-wrap"><div class="mvp-main-box-cont relative"><ul class="mvp-post-trend-list left relative"><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/inside-miamis-2021-recruiting-class-a-look-at-all-21-signees/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/ggg-80x80.png" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/ggg-80x80.png 80w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/ggg-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Hurricanes</h3> <a href="https://www.305sports.net/inside-miamis-2021-recruiting-class-a-look-at-all-21-signees/" rel="bookmark">Inside Miami&#8217;s 2021 Recruiting Class: A Look At All 21 Signees</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/fitzpatrick-delivers-but-tua-remains-under-center-right-or-wrong-move/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1293254642.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/fitzpatrick-delivers-but-tua-remains-under-center-right-or-wrong-move/" rel="bookmark">Fitzpatrick Delivers, But Tua Remains Under Center: Right Or Wrong Move?</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/brian-flores-the-real-mvp-of-2020/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/93257ba20fe64afbb3e48c0027db17a8-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/brian-flores-the-real-mvp-of-2020/" rel="bookmark">Brian Flores: The Real MVP Of 2020</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2021/01/1293245805.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/how-miamis-running-game-has-gone-from-zero-to-hero-in-two-weeks/" rel="bookmark">How Miami&#8217;s Running Game Has Gone From Zero To Hero In Two Weeks</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li></ul> <span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span></div><!--mvp-main-box-cont--></div><!--mvp-post-trend-wrap--><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><!--mvp-fly-top--><div class="mvp-fly-fade mvp-fly-but-click"></div><!--mvp-fly-fade--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>/* <![CDATA[ */
var mdp_deblocker = {"style":"compact","timeout":"0","closeable":"true","title":"It Looks Like You Have AdBlocker Enabled","content":"<p>Please disable AdBlock to proceed to the destination page.<p>","bg_color":"rgba(0,0,0,0.65)","modal_color":"rgba(255,255,255,1)","text_color":"#23282d","blur":"true"};
/* ]]> */</script> <script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script> </body></html>