<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://www.305sports.net/xmlrpc.php" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="The Miami Dolphins have added a second long snapper to the team, signing rookie Rex Sunahara on Saturday. Sunahara served as West Virginia&#8217;s primary long snapper for each of the past two seasons and was selected to play in both the NFLPA Collegiate All-Star Game and the Hula Bowl. The 6-foot-6, 242-pound Sunahara was a [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/"><meta name="twitter:title" content="Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List"><meta name="twitter:description" content="The Miami Dolphins have added a second long snapper to the team, signing rookie Rex Sunahara on Saturday. Sunahara served as West Virginia&#8217;s primary long snapper for each of the past two seasons and was selected to play in both the NFLPA Collegiate All-Star Game and the Hula Bowl. The 6-foot-6, 242-pound Sunahara was a [&hellip;]"> <script>var et_site_url='https://www.305sports.net';var et_post_id='16558';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script> <!-- This site is optimized with the Yoast SEO plugin v14.0.4 - https://yoast.com/wordpress/plugins/seo/ --><style media="all">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</style><title>Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List - 305Sports</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List - 305Sports" /><meta property="og:description" content="The Miami Dolphins have added a second long snapper to the team, signing rookie Rex Sunahara on Saturday. Sunahara served as West Virginia&#8217;s primary long snapper for each of the past two seasons and was selected to play in both the NFLPA Collegiate All-Star Game and the Hula Bowl. The 6-foot-6, 242-pound Sunahara was a [&hellip;]" /><meta property="og:url" content="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/" /><meta property="og:site_name" content="305Sports" /><meta property="article:published_time" content="2020-08-01T19:47:42+00:00" /><meta property="article:modified_time" content="2020-08-01T20:33:50+00:00" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg" /><meta property="og:image:width" content="768" /><meta property="og:image:height" content="586" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@http://twitter.com/AnthonyYero1" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.305sports.net/#website","url":"https://www.305sports.net/","name":"305Sports","description":"Providing In-Depth Analysis And Coverage Of Miami Sports. ","potentialAction":[{"@type":"SearchAction","target":"https://www.305sports.net/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/#primaryimage","inLanguage":"en-US","url":"https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg","width":768,"height":586},{"@type":"WebPage","@id":"https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/#webpage","url":"https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/","name":"Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List - 305Sports","isPartOf":{"@id":"https://www.305sports.net/#website"},"primaryImageOfPage":{"@id":"https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/#primaryimage"},"datePublished":"2020-08-01T19:47:42+00:00","dateModified":"2020-08-01T20:33:50+00:00","author":{"@id":"https://www.305sports.net/#/schema/person/7abdf371bac1d62f25a912918aee0593"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/"]}]},{"@type":["Person"],"@id":"https://www.305sports.net/#/schema/person/7abdf371bac1d62f25a912918aee0593","name":"Anthony Yero","image":{"@type":"ImageObject","@id":"https://www.305sports.net/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0513ecb9a0e1789183d948a53d81a4e4?s=96&d=mm&r=g","caption":"Anthony Yero"},"description":"Born and raised in Miami, Anthony is the Sports Editor for his school paper and High School B-Ball player. Founder and Owner of 305Sports, Anthony covers all Miami Sports. Follow Anthony on Twitter @AnthonyYero1","sameAs":["https://www.instagram.com/anthonyyero/","https://www.linkedin.com/in/anthony-yero-0b2341116","https://twitter.com/http://twitter.com/AnthonyYero1"]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Feed" href="https://www.305sports.net/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Comments Feed" href="https://www.305sports.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List Comments Feed" href="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.305sports.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style type="text/css">#wpadminbar #wp-admin-bar-my-networks > .ab-item:first-child:before {
                content: "\f325";
                top: 3px;
            }</style><style id='mvp-custom-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /> <script type='text/javascript' src='https://www.305sports.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-156579328-1' async></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-156579328-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.305sports.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.305sports.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.305sports.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.305sports.net/?p=16558' /><link rel="alternate" type="application/json+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#f890e7";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <meta name="generator" content="Site Kit by Google 1.8.1" /><meta property="fb:app_id" content=""><meta property="fb:admins" content=""><div id="fb-root"></div> <script>(function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id))
                        return;
                    js = d.createElement(s);
                    js.id = id;
                    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
                    fjs.parentNode.insertBefore(js, fjs);
                }(document, 'script', 'facebook-jssdk'));</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9318763060154915",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-180x180.png" /><meta name="msapplication-TileImage" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-270x270.png" /> <script src="https://www.305sports.net/wp-content/cache/autoptimize/6/js/autoptimize_d8349ecb9dd7b9177d0b92a53f2991a6.js"></script></head><body class="post-template-default single single-post postid-16558 single-format-standard et_bloom"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a></div><!--mvp-fly-logo--></div><!--mvp-fly-top-in--><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-fly-top-out--></div><!--mvp-fly-menu-top--><div id="mvp-fly-menu-wrap"><nav class="mvp-fly-nav-menu left relative"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li id="menu-item-6263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li id="menu-item-12213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li id="menu-item-12212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li id="menu-item-9011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li id="menu-item-4263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li id="menu-item-8714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li id="menu-item-8951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li id="menu-item-8952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li id="menu-item-8953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU</a></li></ul></li></ul></div></nav></div><!--mvp-fly-menu-wrap--><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-fly-soc-wrap--></div><!--mvp-fly-wrap--><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://www.305sports.net/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><!--mvp-search-box--><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div><!--mvp-search-but-wrap--></div><!--mvp-search-wrap--><header id="mvp-top-head-wrap"><nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-top-nav-menu-but--><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://www.305sports.net/"><img itemprop="logo" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a><h2 class="mvp-logo-title">305Sports</h2></div><!--mvp-top-nav-logo--></div><!--mvp-top-nav-left-in--></div><!--mvp-top-nav-left-out--></div><!--mvp-top-nav-left--></div><!--mvp-top-nav-right-in--><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="https://www.instagram.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/305Sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://www.facebook.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div><!--mvp-top-nav-soc--> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div><!--mvp-top-nav-right--></div><!--mvp-top-nav-right-out--></div><!--mvp-top-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-top-nav-wrap--><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-primary-container"><ul id="menu-primary-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU</a></li></ul></li></ul></div></div><!--mvp-nav-menu--></div><!--mvp-bot-nav-in--></div><!--mvp-bot-nav-out--></div><!--mvp-bot-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-bot-nav-wrap--></nav><!--mvp-main-nav-wrap--></header><main id="mvp-main-wrap" class="left relative"><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-16558 post type-post status-publish format-standard has-post-thumbnail hentry category-miami-dolphins tag-featured tag-long-snapper tag-miami-dolphins tag-rex-sunahara" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/"/><div id="mvp-article-head" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.305sports.net/category/miami-dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List</h1><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/0513ecb9a0e1789183d948a53d81a4e4?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0513ecb9a0e1789183d948a53d81a4e4?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.305sports.net/author/305sports/" title="Posts by Anthony Yero" rel="author">Anthony Yero</a></span></li><li class="mvp-author-info-twit"> <a href="https://twitter.com/AnthonyYero1" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-08-01">August 1, 2020</time></span><meta itemprop="dateModified" content="2020-08-01"/></li></ul></div><!--mvp-author-info-wrap--></div><!--mvp-article-head--><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/&amp;t=Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List -&amp;url=https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg&amp;description=Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#0c337f796e66696f78314863607c6465627f2c5f656b622c4063626b2c5f626d7c7c697e2c5e69742c5f79626d646d7e6d2c4d6a78697e2c4e606d67692c4a697e6b797f63622c406d62687f2c43622c4f435a45482c40657f782a6d617c374e43485531452c6a637962682c7864657f2c6d7e78656f60692c656278697e697f7865626b2c6d62682c786463796b64782c636a2c7f646d7e65626b2c65782c7b6578642c756379222c4f64696f672c65782c637978362c6478787c7f3623237b7b7b223f3c397f7c637e787f22626978236863607c6465627f217f656b62216063626b217f626d7c7c697e217e6974217f79626d646d7e6d216d6a78697e216e606d6769216a697e6b797f636221606d62687f216362216f637a65682160657f7823"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/#respond"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="768" height="586" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1-300x229.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1-610x465.jpg 610w" sizes="(max-width: 768px) 100vw, 768px" /><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg"><meta itemprop="width" content="768"><meta itemprop="height" content="586"></div><!--mvp-post-feat-img--> <span class="mvp-feat-caption">Frank Salucci/Blue &amp; Gold News</span><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/" data-a2a-title="Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><style>.fb_iframe_widget span{width:460px !important;} .fb_iframe_widget iframe {margin: 0 !important;}        .fb_edge_comment_widget { display: none !important; }</style><div style="width:100%; text-align:left"><div class="fb-like" style="width:450px; overflow: hidden !important; " data-href="https://www.facebook.com/305sportss/" data-size="small" data-colorscheme="light" data-width="450" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false" kid_directed_site="false"></div></div><p>The <a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a> have added a second long snapper to the team, signing rookie Rex Sunahara on Saturday.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Congrats to <a href="https://twitter.com/RexSunahara?ref_src=twsrc%5Etfw">@RexSunahara</a> on signing with the <a href="https://twitter.com/MiamiDolphins?ref_src=twsrc%5Etfw">@MiamiDolphins</a>! Pen to paper 💯<a href="https://twitter.com/hashtag/HailWV?src=hash&amp;ref_src=twsrc%5Etfw">#HailWV</a> <a href="https://t.co/dVPHDGywBG">pic.twitter.com/dVPHDGywBG</a></p>&mdash; WVU Football (@WVUfootball) <a href="https://twitter.com/WVUfootball/status/1289560579963629570?ref_src=twsrc%5Etfw">August 1, 2020</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p>Sunahara served as West Virginia&#8217;s primary long snapper for each of the past two seasons and was selected to play in both the NFLPA Collegiate All-Star Game and the Hula Bowl.</p><p>The 6-foot-6, 242-pound Sunahara was a semifinalist for the 2019 Patrick Mannelly Award, which is given to the nation&#8217;s top long snapper</p><p>The Dolphins&#8217; other long snapper is rookie Blake Ferguson, who was drafted in the sixth round (No. 185 overall). Ferguson was <a href="https://www.305sports.net/covid-19-strikes-miami-dolphins-as-they-make-roster-moves/">placed on the reserve/COVID-19 list on Monday,</a> which opens the door for an extra roster spot.</p><p>The roster stands at 78 players with the moves Saturday, but will rise to 82 once <a href="https://www.305sports.net/dolphins-lb-jerome-baker-dt-zach-sieler-placed-on-reserve-covid-19-list/">Jerome Baker</a>, <a href="https://www.305sports.net/dolphins-lb-jerome-baker-dt-zach-sieler-placed-on-reserve-covid-19-list/">Zach Sieler</a>, Ferguson and <a href="https://www.305sports.net/covid-19-strikes-miami-dolphins-as-they-make-roster-moves/">Cordea Tankersley</a> come off the reserve/COVID-19 list. It’ll climb to 84 players <a href="https://www.305sports.net/xavien-howard-to-start-training-camp-on-pup-list-as-he-recovers-from-knee-injury/">once/if Xavien Howard and Calvin Munson are reactivated</a>. Miami will have to trim their roster to 81 by August 16.</p><p>Teams could have up to 90 players in camp if they split practice sessions into two squads, which could require teams to use both stadium and regular practice facilities,&nbsp;<a href="https://twitter.com/mortreport/status/1286731000987484160?s=20">per ESPN’s Chris Mortensen</a>.</p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/" data-a2a-title="Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fdolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list%2F&amp;linkname=Dolphins%20Sign%20Long%20Snapper%20Rex%20Sunahara%20After%20Blake%20Ferguson%20Lands%20On%20COVID%20List" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.305sports.net/tag/featured/" rel="tag">featured</a><a href="https://www.305sports.net/tag/long-snapper/" rel="tag">Long Snapper</a><a href="https://www.305sports.net/tag/miami-dolphins/" rel="tag">Miami Dolphins</a><a href="https://www.305sports.net/tag/rex-sunahara/" rel="tag">Rex Sunahara</a></span></div><!--mvp-post-tags--><div class="posts-nav-link"></div><!--posts-nav-link--><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"/><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"></div><!--mvp-org-logo--><meta itemprop="name" content="305Sports"></div><!--mvp-org-wrap--></div><!--mvp-content-main--><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text">Click to comment</span></div><!--mvp-comments-button--><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.305sports.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p><p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='16558' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!--comments--></div><!--mvp-post-soc-in--></div><!--mvp-post-soc-out--></div><!--mvp-content-box--></div><!--mvp-post-content--></div><!--mvp-post-content-in--><div id="mvp-side-wrap" class="relative"></div><!--mvp-side-wrap--></div><!--mvp-post-content-out--><section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Miami Dolphins</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://www.305sports.net/challenge-flag-nfl-network-names-mike-gesicki-as-dolphins-2020-most-improved-player/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/challenge-flag-nfl-network-names-mike-gesicki-as-dolphins-2020-most-improved-player/" rel="bookmark">Challenge Flag: NFL Network Names Mike Gesicki As Dolphins&#8217; 2020 Most Improved Player</a></h2><p>The Miami Dolphins hold a number of players destined for a breakout and much...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/dolphins-lb-jerome-baker-dt-zach-sieler-placed-on-reserve-covid-19-list/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/1087220336.jpg.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/1087220336.jpg.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/1087220336.jpg.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/1087220336.jpg.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/1087220336.jpg.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/1087220336.jpg.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/dolphins-lb-jerome-baker-dt-zach-sieler-placed-on-reserve-covid-19-list/" rel="bookmark">Dolphins&#8217; LB Jerome Baker, DT Zach Sieler Placed On Reserve/Covid-19 List</a></h2><p>The number of Miami Dolphins players that have been affected by COVID-19 continued to...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/opinion-is-tua-tagovailoa-what-the-miami-dolphins-have-been-waiting-for/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/opinion-is-tua-tagovailoa-what-the-miami-dolphins-have-been-waiting-for/" rel="bookmark">Opinion: Is Tua Tagovailoa What The Miami Dolphins Have Been Waiting For?</a></h2><p>To be fair, I’d like to make clear that I never wished for Tua...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/dolphins-rb-malcolm-perry-and-lb-andrew-van-ginkel-recover-from-covid-19-donate-plasma/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-400x240.jpeg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/dolphins-rb-malcolm-perry-and-lb-andrew-van-ginkel-recover-from-covid-19-donate-plasma/" rel="bookmark">Dolphins&#8217; RB Malcolm Perry And LB Andrew Van Ginkel Recover From COVID-19, Donate Plasma</a></h2><p>In the midst of a global pandemic, the Miami Dolphins are one of several...</p></div><!--mvp-more-post-text--></li></ul></section><!--mvp-more-post-wrap--><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/challenge-flag-nfl-network-names-mike-gesicki-as-dolphins-2020-most-improved-player/" rel="prev">Challenge Flag: NFL Network Names Mike Gesicki As Dolphins&#8217; 2020 Most Improved Player</a></div><!--mvp-prev-post-text--></div><!--mvp-prev-post-wrap--></div><!--mvp-prev-next-wrap--></div><!--mvp-sec-pad--></article><!--mvp-article-wrap--></div><!--mvp-main-body--></div><!--mvp-main-box-cont--></div><!--mvp-main-body-wrap--></main><!--mvp-main-wrap--><footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="" alt="305Sports" data-rjs="2" /></a></div><!--mvp-foot-logo--><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-foot-soc--></div><!--mvp-main-box-cont--></div><!--mvp-foot-top--><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"></div><!--mvp-foot-menu--></div><!--mvp-main-box-cont--></div><!--mvp-foot-menu-wrap--><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>305 SPORTS ENTERPRISES, INC.</p></div><!--mvp-foot-copy--></div><!--mvp-main-box-cont--></div><!--mvp-foot-copy-wrap--></div><!--mvp-foot-bot--></footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/&amp;t=Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List -&amp;url=https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/dolphins-sign-long-snapper-rex-sunahara-after-blake-ferguson-lands-on-covid-list/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/08/WVU-football-0902-Rex-Sunahara-on-bench-front-768x586-1.jpg&amp;description=Dolphins Sign Long Snapper Rex Sunahara After Blake Ferguson Lands On COVID List', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#536c202631393630276e173c3f233b3a3d2073003a343d731f3c3d3473003d32232336217301362b7300263d323b32213273123527362173113f323836731536213426203c3d731f323d3720731c3d73101c051a17731f3a202775323e2368111c170a6e1a73353c263d3773273b3a20733221273a303f36733a3d2736213620273a3d3473323d3773273b3c26343b27733c3573203b32213a3d34733a2773243a273b732a3c267d73103b363038733a27733c262769733b27272320697c7c2424247d60636620233c2127207d3d36277c373c3f233b3a3d207e203a343d7e3f3c3d347e203d32232336217e21362b7e20263d323b3221327e32352736217e313f3238367e3536213426203c3d7e3f323d37207e3c3d7e303c253a377e3f3a20277c"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--></div><!--mvp-site--><div id="mvp-post-trend-wrap"><div class="mvp-main-box-cont relative"><ul class="mvp-post-trend-list left relative"><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/opinion-is-tua-tagovailoa-what-the-miami-dolphins-have-been-waiting-for/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/hi-res-761a9ae387aae6647cb4bd398e056bc8_crop_north-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/opinion-is-tua-tagovailoa-what-the-miami-dolphins-have-been-waiting-for/" rel="bookmark">Opinion: Is Tua Tagovailoa What The Miami Dolphins Have Been Waiting For?</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/what-if-the-stars-align-for-the-miami-hurricanes-2021-recruiting-class/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/5D30F337-7ECC-478E-B65E-9A9038D36B31-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/5D30F337-7ECC-478E-B65E-9A9038D36B31-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/5D30F337-7ECC-478E-B65E-9A9038D36B31-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Hurricanes</h3> <a href="https://www.305sports.net/what-if-the-stars-align-for-the-miami-hurricanes-2021-recruiting-class/" rel="bookmark">What If The Stars Align For The Miami Hurricanes&#8217; 2021 Recruiting Class?</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/challenge-flag-nfl-network-names-mike-gesicki-as-dolphins-2020-most-improved-player/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/08/usa_today_11076502.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/challenge-flag-nfl-network-names-mike-gesicki-as-dolphins-2020-most-improved-player/" rel="bookmark">Challenge Flag: NFL Network Names Mike Gesicki As Dolphins&#8217; 2020 Most Improved Player</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/dolphins-rb-malcolm-perry-and-lb-andrew-van-ginkel-recover-from-covid-19-donate-plasma/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/07/CA7FF1F5-13A9-4803-B1F1-E765975B3C94-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/dolphins-rb-malcolm-perry-and-lb-andrew-van-ginkel-recover-from-covid-19-donate-plasma/" rel="bookmark">Dolphins&#8217; RB Malcolm Perry And LB Andrew Van Ginkel Recover From COVID-19, Donate Plasma</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li></ul> <span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span></div><!--mvp-main-box-cont--></div><!--mvp-post-trend-wrap--><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><!--mvp-fly-top--><div class="mvp-fly-fade mvp-fly-but-click"></div><!--mvp-fly-fade--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script> </body></html>