<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://www.305sports.net/xmlrpc.php" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-1000x600.jpg" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-1000x600.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="Records are meant to be broken, right? Not necessarily. Some records just seem to be out of reach. For instance, Cal Ripken Jr.&#8217;s MLB record for consecutive games played with 2,632. No active player has been even close to &#8220;The Iron Man&#8221; and his streak, the nearest being above 300 games.&nbsp; Wayne Gretzky is called [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://www.305sports.net/another-perfect-season/"><meta name="twitter:title" content="Another Perfect Season?"><meta name="twitter:description" content="Records are meant to be broken, right? Not necessarily. Some records just seem to be out of reach. For instance, Cal Ripken Jr.&#8217;s MLB record for consecutive games played with 2,632. No active player has been even close to &#8220;The Iron Man&#8221; and his streak, the nearest being above 300 games.&nbsp; Wayne Gretzky is called [&hellip;]"> <script>var et_site_url='https://www.305sports.net';var et_post_id='8095';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script><style media="all">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</style><title>Another Perfect Season? - 305Sports</title> <!-- This site is optimized with the Yoast SEO plugin v13.4 - https://yoast.com/wordpress/plugins/seo/ --><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://www.305sports.net/another-perfect-season/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Another Perfect Season? - 305Sports" /><meta property="og:description" content="Records are meant to be broken, right? Not necessarily. Some records just seem to be out of reach. For instance, Cal Ripken Jr.&#8217;s MLB record for consecutive games played with 2,632. No active player has been even close to &#8220;The Iron Man&#8221; and his streak, the nearest being above 300 games.&nbsp; Wayne Gretzky is called &hellip;" /><meta property="og:url" content="https://www.305sports.net/another-perfect-season/" /><meta property="og:site_name" content="305Sports" /><meta property="article:author" content="https://www.facebook.com/jamiebahama" /><meta property="article:tag" content="1972" /><meta property="article:tag" content="Don Shula" /><meta property="article:tag" content="featured" /><meta property="article:tag" content="Miami Dolphins" /><meta property="article:tag" content="Miami Dolphins 1972" /><meta property="article:section" content="Miami Dolphins" /><meta property="article:published_time" content="2020-05-10T13:37:24+00:00" /><meta property="article:modified_time" content="2020-05-10T13:38:52+00:00" /><meta property="og:updated_time" content="2020-05-10T13:38:52+00:00" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72.jpg" /><meta property="og:image:secure_url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Records are meant to be broken, right? Not necessarily. Some records just seem to be out of reach. For instance, Cal Ripken Jr.&#8217;s MLB record for consecutive games played with 2,632. No active player has been even close to &#8220;The Iron Man&#8221; and his streak, the nearest being above 300 games.&nbsp; Wayne Gretzky is called [&hellip;]" /><meta name="twitter:title" content="Another Perfect Season? - 305Sports" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72.jpg" /><meta name="twitter:creator" content="@TheJamieBahamas" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.305sports.net/#website","url":"https://www.305sports.net/","name":"305Sports","inLanguage":"en-US","description":"Providing In-Depth Analysis And Coverage Of Miami Sports. ","potentialAction":[{"@type":"SearchAction","target":"https://www.305sports.net/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://www.305sports.net/another-perfect-season/#primaryimage","inLanguage":"en-US","url":"https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72.jpg","width":1200,"height":675},{"@type":"WebPage","@id":"https://www.305sports.net/another-perfect-season/#webpage","url":"https://www.305sports.net/another-perfect-season/","name":"Another Perfect Season? - 305Sports","isPartOf":{"@id":"https://www.305sports.net/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.305sports.net/another-perfect-season/#primaryimage"},"datePublished":"2020-05-10T13:37:24+00:00","dateModified":"2020-05-10T13:38:52+00:00","author":{"@id":"https://www.305sports.net/#/schema/person/58e49f2fb6565a32ca6973a3d1da994a"},"potentialAction":[{"@type":"ReadAction","target":["https://www.305sports.net/another-perfect-season/"]}]},{"@type":["Person"],"@id":"https://www.305sports.net/#/schema/person/58e49f2fb6565a32ca6973a3d1da994a","name":"Jamie Bahamas","image":{"@type":"ImageObject","@id":"https://www.305sports.net/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/986de77725d7d5df301b21f4cd114927?s=96&d=mm&r=g","caption":"Jamie Bahamas"},"description":"Miami Dolphins Writer for 305Sports. \r\n\r\nFollow me on Twitter: @TheJamieBahamas","sameAs":["https://www.facebook.com/jamiebahama","https://twitter.com/https://twitter.com/TheJamieBahamas"]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Feed" href="https://www.305sports.net/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Comments Feed" href="https://www.305sports.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Another Perfect Season? Comments Feed" href="https://www.305sports.net/another-perfect-season/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.305sports.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style type="text/css">#wpadminbar #wp-admin-bar-my-networks > .ab-item:first-child:before {
                content: "\f325";
                top: 3px;
            }</style><style id='mvp-custom-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /> <script type='text/javascript' src='https://www.305sports.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-156579328-1' async></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-156579328-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.305sports.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.305sports.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.305sports.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='https://www.305sports.net/?p=8095' /><link rel="alternate" type="application/json+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#f890e7";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <meta name="generator" content="Site Kit by Google 1.6.0" /><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9318763060154915",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-180x180.png" /><meta name="msapplication-TileImage" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-270x270.png" /> <script src="https://www.305sports.net/wp-content/cache/autoptimize/6/js/autoptimize_d8349ecb9dd7b9177d0b92a53f2991a6.js"></script></head><body class="post-template-default single single-post postid-8095 single-format-standard et_bloom"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a></div><!--mvp-fly-logo--></div><!--mvp-fly-top-in--><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-fly-top-out--></div><!--mvp-fly-menu-top--><div id="mvp-fly-menu-wrap"><nav class="mvp-fly-nav-menu left relative"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li id="menu-item-361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li id="menu-item-6263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li id="menu-item-100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-100"><a href="https://www.305sports.net/category/dade-sports/">Miami-Dade Sports</a><ul class="sub-menu"><li id="menu-item-98" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98"><a href="https://www.305sports.net/category/dade-b-ball/">Miami-Dade Basketball</a></li><li id="menu-item-99" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99"><a href="https://www.305sports.net/category/dade-fball/">Miami-Dade Football</a></li></ul></li><li id="menu-item-6265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6265"><a href="https://www.305sports.net/category/broward-county/">Broward County</a></li><li id="menu-item-6266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6266"><a href="https://www.305sports.net/category/palm-beach-county/">Palm Beach County</a></li></ul></li><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li id="menu-item-4263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li></ul></div></nav></div><!--mvp-fly-menu-wrap--><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-fly-soc-wrap--></div><!--mvp-fly-wrap--><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://www.305sports.net/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><!--mvp-search-box--><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div><!--mvp-search-but-wrap--></div><!--mvp-search-wrap--><header id="mvp-top-head-wrap"><nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-top-nav-menu-but--><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://www.305sports.net/"><img itemprop="logo" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a><h2 class="mvp-logo-title">305Sports</h2></div><!--mvp-top-nav-logo--></div><!--mvp-top-nav-left-in--></div><!--mvp-top-nav-left-out--></div><!--mvp-top-nav-left--></div><!--mvp-top-nav-right-in--><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="https://www.instagram.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/305Sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://www.facebook.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div><!--mvp-top-nav-soc--> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div><!--mvp-top-nav-right--></div><!--mvp-top-nav-right-out--></div><!--mvp-top-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-top-nav-wrap--><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-primary-container"><ul id="menu-primary-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-100"><a href="https://www.305sports.net/category/dade-sports/">Miami-Dade Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-98"><a href="https://www.305sports.net/category/dade-b-ball/">Miami-Dade Basketball</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99"><a href="https://www.305sports.net/category/dade-fball/">Miami-Dade Football</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6265"><a href="https://www.305sports.net/category/broward-county/">Broward County</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6266"><a href="https://www.305sports.net/category/palm-beach-county/">Palm Beach County</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li></ul></div></div><!--mvp-nav-menu--></div><!--mvp-bot-nav-in--></div><!--mvp-bot-nav-out--></div><!--mvp-bot-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-bot-nav-wrap--></nav><!--mvp-main-nav-wrap--></header><main id="mvp-main-wrap" class="left relative"><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-8095 post type-post status-publish format-standard has-post-thumbnail hentry category-miami-dolphins tag-787 tag-don-shula tag-featured tag-miami-dolphins tag-miami-dolphins-1972" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.305sports.net/another-perfect-season/"/><div id="mvp-article-head" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.305sports.net/category/miami-dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">Another Perfect Season?</h1><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/986de77725d7d5df301b21f4cd114927?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/986de77725d7d5df301b21f4cd114927?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.305sports.net/author/jamiebahamas/" title="Posts by Jamie Bahamas" rel="author">Jamie Bahamas</a></span></li><li class="mvp-author-info-twit"> <a href="https://twitter.com/TheJamieBahamas" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-05-10">May 10, 2020</time></span><meta itemprop="dateModified" content="2020-05-10"/></li></ul></div><!--mvp-author-info-wrap--></div><!--mvp-article-head--><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/another-perfect-season/&amp;t=Another Perfect Season?', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Another Perfect Season? -&amp;url=https://www.305sports.net/another-perfect-season/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/another-perfect-season/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-1000x600.jpg&amp;description=Another Perfect Season?', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#506f2325323a3533246d113e3f24383522700035223635332470033531233f3e6f76313d206b121f14096d1970363f253e3470243839237031222439333c3570393e243522352324393e3770313e347024383f25373824703f367023383122393e37703924702739243870293f257e70133835333b703924703f25246a7038242420236a7f7f2727277e63606523203f2224237e3e35247f313e3f243835227d203522363533247d233531233f3e7f"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="https://www.305sports.net/another-perfect-season/#respond"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="1200" height="675" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72.jpg 1200w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-300x169.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-1024x576.jpg 1024w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-768x432.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-610x343.jpg 610w" sizes="(max-width: 1200px) 100vw, 1200px" /><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-1000x600.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="600"></div><!--mvp-post-feat-img--> <span class="mvp-feat-caption">CBSSports</span><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/another-perfect-season/" data-a2a-title="Another Perfect Season?"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p>Records are meant to be broken, right?</p><p>Not necessarily. Some records just seem to be out of reach. For instance, Cal Ripken Jr.&#8217;s MLB record for consecutive games played with 2,632. No active player has been even close to &#8220;The Iron Man&#8221; and his streak, the nearest being above 300 games.&nbsp;</p><p>Wayne Gretzky is called “The Great One” and rightfully so. Gretzky holds the NHL record for career points scored with 2,857. The closest active player to him is Joe Thornton with 1,566 points. Thornton is 40 years old and the second oldest active player in the league, making it almost impossible that he will catch Gretzky’s record.&nbsp;</p><h3><strong>Welcome to Perfectville &#8211; Population 1</strong></h3><p>Then there’s the 1972 Miami Dolphins who were coached by the NFL’s winningest coach of all-time, Don Shula. The 72&#8242; Dolphins are the only team in NFL history to complete the perfect season. Miami finished the season 17-0, winning 14 regular-season games, two playoff games, and Super Bowl VII.&nbsp;</p><p>The 1962 Green Bay Packers, 1976 Oakland Raiders, 1984 San Francisco 49ers, and 1985 Chicago Bears all came close, losing one regular-season game each. Perhaps no team came closer than the 2007 New England Patriots, who made it all the way to Super Bowl XLII before losing to the NY Giants and the memorable David Tyree &#8216;Helmet Catch.&#8217;&nbsp;</p><p>With five teams getting so close to cracking the impossible, I would bet money that this record is in fact, breakable.</p><p>Looking at the team that got the closest, New England was 1<sup>st</sup> in total offense and 4<sup>th</sup> in total defense in 2007. That Patriots team also set NFL Records for highest point differential for a season at +315. This signifies that for a team to go perfect, they must play perfect.&nbsp;</p><h5>Here&#8217;s where the challenge comes in for any team hoping to break this record.</h5><p>Assuming that a team in quest of the perfect season is guaranteed a playoff bye-week, that team then ultimately has to win 19 games. Not only does a team have to be ready to play every game, they have to hope that they don’t incur major injuries or sustain winning despite losing key players to injuries.&nbsp;</p><p>There are other factors that increase the level of difficulty. The NFL schedule now consists of Monday, Thursday, and Saturday games. Teams can have a short turnaround week which could ultimately leave them at enough of a disadvantage to drop a game that they would have otherwise won.&nbsp;</p><p>If you consider International games, things really get daunting. Since 2007, each season has consisted of a there few games scheduled in London and Mexico. That overseas travel could interrupt a team&#8217;s chance of staying perfect.</p><h3><strong>Could 2020 Be the Year? </strong></h3><p>The 2020 season might be the best chance that a team may ever have again to capture this elusive record. 2020 will be the last season in which teams will play a 16 game regular season. The league will increase to 17 regular-season games in 2021, further decreasing the odds of going perfect.&nbsp;</p><p>The Coronavirus pandemic has also canceled all international games next season, adding another reason to think 2020 could be the best chance. On the other side of that coin, the coronavirus pandemic is preventing teams from executing their routines in preparation for the upcoming season.</p><p>Lastly, teams likely that would threaten that record would be the teams led by the last three NFL season MVPs; Tom Brady, Patrick Mahomes, and Lamar Jackson. As fate would have it, The Tampa Bay Buccaneers, Kansas City Chiefs, and Baltimore Ravens all cross paths this season, decreasing the likelihood that one of these teams would pull off the perfect season in 2020.</p><p>It’s certainly not in the realm of impossibility, however, NFL teams have their work cut out for them if they ever wish to do what only one team has ever done before.&nbsp;</p><p><strong>Don Shula and the 1972 Miami Dolphins. Forever Perfect.</strong></p><p><em>For more Miami Dolphins Football, like us on&nbsp;</em><a rel="noreferrer noopener" href="https://www.facebook.com/305sportss/?eid=ARDyHsdlsBlBN8PrxWU48F3N11H_VJwgQ90JMoZbwnM0eoe_dA5I0Knr2BBQ_rNwA_rwEoL9B3evwRef" target="_blank">Facebook</a><em>&nbsp;and follow me on Twitter&nbsp;</em><a rel="noreferrer noopener" href="https://twitter.com/TheJamieBahamas" target="_blank">@TheJamieBahamas</a></p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/another-perfect-season/" data-a2a-title="Another Perfect Season?"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fanother-perfect-season%2F&amp;linkname=Another%20Perfect%20Season%3F" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.305sports.net/tag/1972/" rel="tag">1972</a><a href="https://www.305sports.net/tag/don-shula/" rel="tag">Don Shula</a><a href="https://www.305sports.net/tag/featured/" rel="tag">featured</a><a href="https://www.305sports.net/tag/miami-dolphins/" rel="tag">Miami Dolphins</a><a href="https://www.305sports.net/tag/miami-dolphins-1972/" rel="tag">Miami Dolphins 1972</a></span></div><!--mvp-post-tags--><div class="posts-nav-link"></div><!--posts-nav-link--><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"/><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"></div><!--mvp-org-logo--><meta itemprop="name" content="305Sports"></div><!--mvp-org-wrap--></div><!--mvp-content-main--><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text">Click to comment</span></div><!--mvp-comments-button--><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/another-perfect-season/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.305sports.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p><p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8095' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!--comments--></div><!--mvp-post-soc-in--></div><!--mvp-post-soc-out--></div><!--mvp-content-box--></div><!--mvp-post-content--></div><!--mvp-post-content-in--><div id="mvp-side-wrap" class="relative"></div><!--mvp-side-wrap--></div><!--mvp-post-content-out--><section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Miami Dolphins</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://www.305sports.net/305talks-ep-3-dolphins-schedule/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-400x240.png" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-400x240.png 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-80x80.png" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-80x80.png 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/305talks-ep-3-dolphins-schedule/" rel="bookmark">305Talks Ep. 3 Dolphins Schedule</a></h2><p>On Episode 3 of 305Talks, Michael, Anthony, Jamie, and Robbie discuss the Miami Dolphins...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/could-miami-make-a-playoff-run/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-400x240.jpeg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/could-miami-make-a-playoff-run/" rel="bookmark">Could Miami Make A Playoff Run?</a></h2><p>In my opinion, this offseason has been one of the greatest for the Miami...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/dolphins-2020-wide-receivers-hot-seat-volume-1/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/dolphins-2020-wide-receivers-hot-seat-volume-1/" rel="bookmark">Dolphins 2020 Wide Receivers Hot Seat: Volume 1</a></h2><p>The Miami Dolphins continue to overhaul their roster as part of the rebuild. In...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/miami-dolphins-2020-schedule-analysis/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/unnamed-6-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/unnamed-6-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/unnamed-6-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/unnamed-6-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/unnamed-6-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/unnamed-6-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/miami-dolphins-2020-schedule-analysis/" rel="bookmark">Miami Dolphins 2020 Schedule Analysis</a></h2><p>In the age of the Coronavirus, the NFL found a way to keep Free...</p></div><!--mvp-more-post-text--></li></ul></section><!--mvp-more-post-wrap--><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/305talks-ep-3-dolphins-schedule/" rel="prev">305Talks Ep. 3 Dolphins Schedule</a></div><!--mvp-prev-post-text--></div><!--mvp-prev-post-wrap--></div><!--mvp-prev-next-wrap--></div><!--mvp-sec-pad--></article><!--mvp-article-wrap--></div><!--mvp-main-body--></div><!--mvp-main-box-cont--></div><!--mvp-main-body-wrap--></main><!--mvp-main-wrap--><footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="" alt="305Sports" data-rjs="2" /></a></div><!--mvp-foot-logo--><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-foot-soc--></div><!--mvp-main-box-cont--></div><!--mvp-foot-top--><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"></div><!--mvp-foot-menu--></div><!--mvp-main-box-cont--></div><!--mvp-foot-menu-wrap--><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>Copyright © 2020 305Sports</p></div><!--mvp-foot-copy--></div><!--mvp-main-box-cont--></div><!--mvp-foot-copy-wrap--></div><!--mvp-foot-bot--></footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/another-perfect-season/&amp;t=Another Perfect Season?', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Another Perfect Season? -&amp;url=https://www.305sports.net/another-perfect-season/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/another-perfect-season/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/05/fins72-1000x600.jpg&amp;description=Another Perfect Season?', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#350a4640575f50564108745b5a415d5047156550475350564115665054465a5b0a135458450e777a716c087c15535a405b5115415d5c46155447415c565950155c5b4150475046415c5b5215545b5115415d5a40525d41155a5315465d54475c5b52155c4115425c415d154c5a401b15765d50565e155c41155a40410f155d414145460f1a1a4242421b06050046455a4741461b5b50411a545b5a415d5047184550475350564118465054465a5b1a"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--></div><!--mvp-site--><div id="mvp-post-trend-wrap"><div class="mvp-main-box-cont relative"><ul class="mvp-post-trend-list left relative"><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/could-miami-make-a-playoff-run/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1190730586-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/could-miami-make-a-playoff-run/" rel="bookmark">Could Miami Make A Playoff Run?</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/dolphins-2020-wide-receivers-hot-seat-volume-1/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1179861279-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/dolphins-2020-wide-receivers-hot-seat-volume-1/" rel="bookmark">Dolphins 2020 Wide Receivers Hot Seat: Volume 1</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/could-the-canes-land-taulia-tagovailoa/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1183670883-1-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1183670883-1-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/1183670883-1-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Hurricanes</h3> <a href="https://www.305sports.net/could-the-canes-land-taulia-tagovailoa/" rel="bookmark">Could The Canes Land Taulia Tagovailoa?</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/305talks-ep-3-dolphins-schedule/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-80x80.png" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-80x80.png 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/05/305TLKS-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/305talks-ep-3-dolphins-schedule/" rel="bookmark">305Talks Ep. 3 Dolphins Schedule</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li></ul> <span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span></div><!--mvp-main-box-cont--></div><!--mvp-post-trend-wrap--><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><!--mvp-fly-top--><div class="mvp-fly-fade mvp-fly-but-click"></div><!--mvp-fly-fade--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script> </body></html>