<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://www.305sports.net/xmlrpc.php" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-1000x600.jpg" /><meta name="twitter:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-1000x600.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="After an emotion-filled Week 13 contest between the Miami Dolphins and the Cincinnati Bengals, the NFL has made its final decision on fines and suspensions. Six days ago, Miami&#8217;s 19-7 win over Cincinnati featured illegal hits, fights and disqualifications. The emotion started to rise after an altercation between Dolphins cornerback Xavien Howard and Bengals tight [&hellip;]" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/"><meta name="twitter:title" content="A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals"><meta name="twitter:description" content="After an emotion-filled Week 13 contest between the Miami Dolphins and the Cincinnati Bengals, the NFL has made its final decision on fines and suspensions. Six days ago, Miami&#8217;s 19-7 win over Cincinnati featured illegal hits, fights and disqualifications. The emotion started to rise after an altercation between Dolphins cornerback Xavien Howard and Bengals tight [&hellip;]"> <script>var et_site_url='https://www.305sports.net';var et_post_id='25419';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}</script> <!-- This site is optimized with the Yoast SEO plugin v14.8 - https://yoast.com/wordpress/plugins/seo/ --><style media="all">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</style><title>A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals - 305Sports</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals - 305Sports" /><meta property="og:description" content="After an emotion-filled Week 13 contest between the Miami Dolphins and the Cincinnati Bengals, the NFL has made its final decision on fines and suspensions. Six days ago, Miami&#8217;s 19-7 win over Cincinnati featured illegal hits, fights and disqualifications. The emotion started to rise after an altercation between Dolphins cornerback Xavien Howard and Bengals tight [&hellip;]" /><meta property="og:url" content="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/" /><meta property="og:site_name" content="305Sports" /><meta property="article:published_time" content="2020-12-13T03:32:24+00:00" /><meta property="article:modified_time" content="2020-12-13T03:32:28+00:00" /><meta property="og:image" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE.jpg" /><meta property="og:image:width" content="1066" /><meta property="og:image:height" content="600" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@www.twitter.com/GabeGlassman" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.305sports.net/#website","url":"https://www.305sports.net/","name":"305Sports","description":"Providing In-Depth Analysis And Coverage Of Miami Sports.","potentialAction":[{"@type":"SearchAction","target":"https://www.305sports.net/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/#primaryimage","inLanguage":"en-US","url":"https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE.jpg","width":1066,"height":600},{"@type":"WebPage","@id":"https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/#webpage","url":"https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/","name":"A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals - 305Sports","isPartOf":{"@id":"https://www.305sports.net/#website"},"primaryImageOfPage":{"@id":"https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/#primaryimage"},"datePublished":"2020-12-13T03:32:24+00:00","dateModified":"2020-12-13T03:32:28+00:00","author":{"@id":"https://www.305sports.net/#/schema/person/b59e1f12c5e790a2fec987771626d31b"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/"]}]},{"@type":"Person","@id":"https://www.305sports.net/#/schema/person/b59e1f12c5e790a2fec987771626d31b","name":"Gabe Glassman","image":{"@type":"ImageObject","@id":"https://www.305sports.net/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=96&d=mm&r=g","caption":"Gabe Glassman"},"description":"Gabe Glassman is an experienced sports broadcaster, having won 5 awards in state-wide and national competitions in the last two years. Gabe spent the last 4 years at Marjory Stoneman Douglas High School with 3 of those years being the Sports Director for WMSD-TV. He has been a South Florida sports fan all of his life. Glassman is currently attending the University of South Florida as a Mass Communications Major. Gabe is excited to get the opportunity to work with the 305 Sports Crew and to write about his favorite sports!","sameAs":["www.instagram.com/officialgabeglassman","https://twitter.com/www.twitter.com/GabeGlassman","www.youtube.com/GabeGlassman"]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Feed" href="https://www.305sports.net/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; Comments Feed" href="https://www.305sports.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="305Sports &raquo; A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals Comments Feed" href="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.305sports.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style type="text/css">#wpadminbar #wp-admin-bar-my-networks > .ab-item:first-child:before {
                content: "\f325";
                top: 3px;
            }</style><style id='mvp-custom-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /> <script type='text/javascript' src='https://www.305sports.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-156579328-1'></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-156579328-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://www.305sports.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.305sports.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.305sports.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.4" /><link rel='shortlink' href='https://www.305sports.net/?p=25419' /><link rel="alternate" type="application/json+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.305sports.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&#038;format=xml" /> <script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
a2a_config.icon_color="#f890e7";
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script> <meta name="generator" content="Site Kit by Google 1.14.0" /><script data-ad-client="ca-pub-9318763060154915" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- VINTCER_DO_NOT_REMOVE --> <script type="text/javascript">var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.www.305sports.net"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//vint-analytics.vintcer.io/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '5']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();</script> <!-- VINTCER_DO_NOT_REMOVE --><meta property="fb:app_id" content=""><meta property="fb:admins" content=""><div id="fb-root"></div> <script>(function (d, s, id) {
                    var js, fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id))
                        return;
                    js = d.createElement(s);
                    js.id = id;
                    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
                    fjs.parentNode.insertBefore(js, fjs);
                }(document, 'script', 'facebook-jssdk'));</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-9318763060154915",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-180x180.png" /><meta name="msapplication-TileImage" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/cropped-unnamed-270x270.png" /> <script src="https://www.305sports.net/wp-content/cache/autoptimize/6/js/autoptimize_d01ef3aa366168ff6e08c3faf50e1dfa.js"></script></head><body class="post-template-default single single-post postid-25419 single-format-standard et_bloom"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a></div><!--mvp-fly-logo--></div><!--mvp-fly-top-in--><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-fly-top-out--></div><!--mvp-fly-menu-top--><div id="mvp-fly-menu-wrap"><nav class="mvp-fly-nav-menu left relative"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-361" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li id="menu-item-96" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li id="menu-item-97" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li id="menu-item-93" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li id="menu-item-95" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li id="menu-item-94" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li id="menu-item-6263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li id="menu-item-12213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li id="menu-item-12212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li id="menu-item-9011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li id="menu-item-92" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li id="menu-item-4263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li id="menu-item-8714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li id="menu-item-8951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li id="menu-item-8952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li id="menu-item-8953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU Panthers</a></li></ul></li></ul></div></nav></div><!--mvp-fly-menu-wrap--><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-fly-soc-wrap--></div><!--mvp-fly-wrap--><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://www.305sports.net/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><!--mvp-search-box--><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div><!--mvp-search-but-wrap--></div><!--mvp-search-wrap--><header id="mvp-top-head-wrap"><nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--></div><!--mvp-top-nav-menu-but--><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://www.305sports.net/"><img itemprop="logo" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png" alt="305Sports" data-rjs="2" /></a><h2 class="mvp-logo-title">305Sports</h2></div><!--mvp-top-nav-logo--></div><!--mvp-top-nav-left-in--></div><!--mvp-top-nav-left-out--></div><!--mvp-top-nav-left--></div><!--mvp-top-nav-right-in--><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="https://www.instagram.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/305Sportss" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://www.facebook.com/305sportss/" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div><!--mvp-top-nav-soc--> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div><!--mvp-top-nav-right--></div><!--mvp-top-nav-right-out--></div><!--mvp-top-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-top-nav-wrap--><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><!--mvp-fly-but-wrap--><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-primary-container"><ul id="menu-primary-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-361"><a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-96"><a href="https://www.305sports.net/category/miami-heat/">Miami Heat</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-97"><a href="https://www.305sports.net/category/miami-marlins/">Miami Marlins</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-93"><a href="https://www.305sports.net/category/miami-hurricanes/">Miami Hurricanes</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-95"><a href="https://www.305sports.net/category/um-football/">Miami Hurricanes Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94"><a href="https://www.305sports.net/category/um-basketball/">Miami Hurricanes Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6263"><a href="https://www.305sports.net/category/high-school-sports/">High School Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12213"><a href="https://www.305sports.net/category/high-school-football/">High School Football</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12212"><a href="https://www.305sports.net/category/high-school-basketball/">High School Basketball</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9011"><a href="https://www.305sports.net/category/other/">Other</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-92"><a href="https://www.305sports.net/about/">About</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4263"><a href="https://www.305sports.net/staff/">Meet The Team</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8714"><a href="https://www.305sports.net/category/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-8951"><a href="https://www.305sports.net/category/soccer/">Soccer</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8952"><a href="https://www.305sports.net/category/inter-miami-cf/">Inter Miami CF</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8953"><a href="https://www.305sports.net/category/miami-fc/">Miami FC</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9010"><a href="https://www.305sports.net/category/fiu/">FIU Panthers</a></li></ul></li></ul></div></div><!--mvp-nav-menu--></div><!--mvp-bot-nav-in--></div><!--mvp-bot-nav-out--></div><!--mvp-bot-nav-cont--></div><!--mvp-main-box-cont--></div><!--mvp-bot-nav-wrap--></nav><!--mvp-main-nav-wrap--></header><main id="mvp-main-wrap" class="left relative"><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-25419 post type-post status-publish format-standard has-post-thumbnail hentry category-miami-dolphins tag-cincinnati-bengals tag-featured tag-miami-dolphins" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/"/><div id="mvp-article-head" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://www.305sports.net/category/miami-dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals</h1><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=46&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=92&#038;d=mm&#038;r=g 2x' class='avatar avatar-46 photo' height='46' width='46' /></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.305sports.net/author/gabeglassman/" title="Posts by Gabe Glassman" rel="author">Gabe Glassman</a></span></li><li class="mvp-author-info-twit"> <a href="www.twitter.com/GabeGlassman" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-12-12">December 12, 2020</time></span><meta itemprop="dateModified" content="2020-12-12"/></li></ul></div><!--mvp-author-info-wrap--></div><!--mvp-article-head--><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/&amp;t=A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals -&amp;url=https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-1000x600.jpg&amp;description=A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#3c034f495e56595f48017d1c7f50534f594e1c70535357061c081c7853504c5455524f1c6c505d45594e4f1c7a555259581c7a535050534b55525b1c7d5048594e5f5d485553524f1c6a594e4f494f1c7e59525b5d504f1a5d514c077e73786501751c5a534952581c4854554f1c5d4e48555f50591c555248594e594f4855525b1c5d52581c485453495b54481c535a1c4f545d4e55525b1c55481c4b5548541c455349121c7f54595f571c55481c534948061c5448484c4f0613134b4b4b120f0c094f4c534e484f12525948135d115f50534f594e11505353571108115853504c5455524f114c505d45594e4f115a55525958115a535050534b55525b115d5048594e5f5d485553524f114a594e4f494f115e59525b5d504f13"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/#respond"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="1066" height="600" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE.jpg 1066w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-300x169.jpg 300w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-1024x576.jpg 1024w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-768x432.jpg 768w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-610x343.jpg 610w" sizes="(max-width: 1066px) 100vw, 1066px" /><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-1000x600.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="600"></div><!--mvp-post-feat-img--> <span class="mvp-feat-caption">Lynne Sladky / Associated Press</span><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/" data-a2a-title="A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><style>.fb_iframe_widget span{width:460px !important;} .fb_iframe_widget iframe {margin: 0 !important;}        .fb_edge_comment_widget { display: none !important; }</style><div style="width:100%; text-align:left"><div class="fb-like" style="width:450px; overflow: hidden !important; " data-href="https://www.facebook.com/305sportss/" data-size="small" data-colorscheme="light" data-width="450" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false" kid_directed_site="false"></div></div><p>After an emotion-filled Week 13 contest between the <a href="https://www.305sports.net/category/miami-dolphins/">Miami Dolphins</a> and the Cincinnati Bengals, the NFL has made its final decision on fines and suspensions.</p><p>Six days ago, Miami&#8217;s 19-7 win over Cincinnati featured illegal hits, fights and disqualifications. The emotion started to rise after an altercation between Dolphins cornerback Xavien Howard and Bengals tight end Tyler Boyd which was a slight scramble that ended in seconds. Both players were ejected, but no fines were issued for either side.</p><figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"> <iframe title="Tyler Boyd vs Xavien Howard FIGHT [Ejected] | HD" width="1000" height="563" src="https://www.youtube.com/embed/IWgswb2t07g?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></figure><p>Later in the game, Cincinnati specialist Mike Thomas illegally hit Miami&#8217;s Jakeem Grant on a punt return. This was not Thomas&#8217; only offense, nailing Grant too early once again, causing sparks to fly on both sidelines, including head coach Brian Flores. From this fight, the officiating crew ejected Bengals safety Shawn Williams and Dolphins wide receivers Devante Parker and Mack Hollins.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">benches are clearing after another dirty hit on jakeem grant <a href="https://t.co/O91L0cBNWA">pic.twitter.com/O91L0cBNWA</a></p>&mdash; josh houtz (@houtz) <a href="https://twitter.com/houtz/status/1335688067001225217?ref_src=twsrc%5Etfw">December 6, 2020</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p>The NFL announced Tuesday that they would release all fines and suspensions Saturday, and they delivered. The end result: one suspension and six fines, with most of them headed Miami&#8217;s direction.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Seven players were fined from last week’s <a href="https://twitter.com/hashtag/Dolphins?src=hash&amp;ref_src=twsrc%5Etfw">#Dolphins</a>&#8211;<a href="https://twitter.com/hashtag/Bengals?src=hash&amp;ref_src=twsrc%5Etfw">#Bengals</a> brawl: <a href="https://t.co/N2gASciPD7">pic.twitter.com/N2gASciPD7</a></p>&mdash; Tom Pelissero (@TomPelissero) <a href="https://twitter.com/TomPelissero/status/1337888242377560071?ref_src=twsrc%5Etfw">December 12, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h3><strong>Cincinnati Bengals Fines and Suspensions:</strong></h3><p><strong>S Shawn Williams: Suspended One Game for Fight/Unnecessary Roughness</strong></p><p>Shawn Williams really sparked the fight between both sides, and that&#8217;s where his one game suspension leads. Something forgotten when issuing penalties is Williams blatantly slammed his foot into Miami offensive lineman Solomon Kindley&#8217;s ankle. Kindley was coming off of the inactive list, right after a foot injury he suffered the week prior. In conclusion, not only did Williams deserve his suspension, but he should&#8217;ve owed the league money for that sequence.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">As if Mike Thomas’ hits on Grant weren’t enough today. Look at number 36 Shawn Williams after this play stepping on Robert Hunt&#8230; <br><br>Classless. <a href="https://t.co/V3m6fgiDAk">pic.twitter.com/V3m6fgiDAk</a></p>&mdash; 𝘿𝙤𝙡𝙥𝙝𝙞𝙣𝙨 🐬🎄 (@FinsPhanatics) <a href="https://twitter.com/FinsPhanatics/status/1335769341233545216?ref_src=twsrc%5Etfw">December 7, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p><strong>CB Mackenzie Alexander: Fined $15,000 for Unnecessary Roughness</strong></p><p>Mackenzie Alexander is coming in with the most expensive payment for doing basically nothing. The NFL gave him, in this situation, a hefty fine for trying to disperse the big fight. In the overhead view, it&#8217;s incredibly hard to even see his number being shown in the mix of it all, but officials found him somewhere, and apparently, he earned a very expensive hit to his bank account.</p><p><strong>WR/Specialist Mike Thomas: Fined $4,853 for Unnecessary Roughness</strong></p><p>This is the fine where Miami probably is most upset about. As mentioned earlier, Thomas had two illegal hits on Miami&#8217;s punt returner Jakeem Grant and was not disqualified for two cheap shots. It&#8217;s the fact where Thomas is escaping this with the least amount of punishment. If anyone should be suspended or ejected, it had to be Thomas by a mile.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Listen to <a href="https://twitter.com/miketirico?ref_src=twsrc%5Etfw">@miketirico</a> call out the league over Mike Thomas not being ejected in this game <a href="https://t.co/ejGAkUiWUB">pic.twitter.com/ejGAkUiWUB</a></p>&mdash; DolphinsTalk.com (@DolphinsTalk) <a href="https://twitter.com/DolphinsTalk/status/1335764065046687744?ref_src=twsrc%5Etfw">December 7, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><h3><strong>Miami Dolphins Fines and Suspensions:</strong></h3><p><strong>DT Christian Wilkins: Fined $12,500 for Unnecessary Roughness </strong></p><p>Coming in with the biggest payment for Miami, Christian Wilkins was also trying to break up a fight. In the video, you can see Wilkins coming in behind teammate Emmanuel Ogbah, who also got fined, trying to break up the brawl. The fine could be for slightly shoving a Bengal. Overall, there isn&#8217;t any other incident where Wilkins was seen in an altercation that the public knows of so far.</p><p><strong>DE Emmanuel Ogbah: Fined $10,500 for Unnecessary Roughness</strong></p><p>How does Ogbah, who didn&#8217;t even throw a punch, get fined the same amount as Parker, who actually threw punches at Cincinnati&#8217;s Williams? Ogbah came into the fight sprinting but didn&#8217;t push, shove, or punch anyone. Instead, it looked like he tried to depress the situation. Even though it seemed like Ogbah wasn&#8217;t in the wrong, the officials found something where they could fine him in this case.</p><figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"> <iframe title="Miami Dolphins bench empties and fight breaks out - Miami Vs Bengals - Multiple ejections" width="1000" height="563" src="https://www.youtube.com/embed/Q1MW4FnxJYo?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></figure><p><strong>WR DeVante Parker: $10,500 for Fight/Unnecessary Roughness</strong></p><p>As expected, Parker surely was ready to pay any amount coming his way. The connection between Parker and Grant is tight, and he didn&#8217;t hold back from standing up for his friend. Miami&#8217;s leading receiver was in the middle of the scuffle and is visibly seen throwing punches at anyone in front of him.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">DeVante Parker starts swinging after Jakeem Grant gets cheap shotted twice <a href="https://t.co/Fw0EitAO0d">pic.twitter.com/Fw0EitAO0d</a></p>&mdash; Dolphin Nation (@Dolphin_Nation) <a href="https://twitter.com/Dolphin_Nation/status/1335696385266515968?ref_src=twsrc%5Etfw">December 6, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p><strong>TE/Specialist Mack Hollins: Two fines totaling $8,824 for Unnecessary Roughness</strong></p><p>Hollins might be new to this team, but he has already grown a strong relationship with his teammates, especially Grant. After Thomas illegally tried to go through his friend&#8217;s body, Hollins also wasn&#8217;t standing down to anyone. What&#8217;s weird is that Mack is paying two separate fines for what seems like one offense.</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Not shown on the broadcast: Here&#39;s Jakeem Grant showing love to DeVante Parker and Mack Hollins for coming to his defense. This team is literally fighting for one another.  (shot by <a href="https://twitter.com/thewiwitos?ref_src=twsrc%5Etfw">@thewiwitos</a>) <a href="https://twitter.com/hashtag/FinsUp?src=hash&amp;ref_src=twsrc%5Etfw">#FinsUp</a> <a href="https://t.co/itB7orYSa5">pic.twitter.com/itB7orYSa5</a></p>&mdash; Mike Cugno (@MikeCugnoCBS4) <a href="https://twitter.com/MikeCugnoCBS4/status/1335747022771675136?ref_src=twsrc%5Etfw">December 7, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p>Luckily, no one got majorly hurt physically or financially on either side as a result of the fights, but something doesn&#8217;t add up. If the officiating crew had enough evidence to eject Howard and Boyd, why wasn&#8217;t  Thomas ejected as a result of his two cheap shots? Why wasn&#8217;t Williams fined for unnecessary roughness on Kindley? Why were Ogbah and Wilkins fined for trying to disperse the fight?</p><p>The entire situation is a complete mess because Dolphins fans will tell you that the Bengals got away with minimal punishment. Cincinnati head coach Zac Taylor even defended his guys, even while knowing that his team was in the wrong. There&#8217;s nothing anyone can do now, but it looks like the Bengals got away with a lot of unnecessary moves on Miami.</p><p>The Dolphins are moving on quickly from last week, as they keep preparing for the hardest end in the NFL, starting off with playing the reigning Super Bowl Champion Kansas City Chiefs.</p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/" data-a2a-title="A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_copy_link" href="https://www.addtoany.com/add_to/copy_link?linkurl=https%3A%2F%2Fwww.305sports.net%2Fa-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals%2F&amp;linkname=A%20Closer%20Look%3A%204%20Dolphins%20Players%20Fined%20Following%20Altercations%20Versus%20Bengals" title="Copy Link" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://www.305sports.net/tag/cincinnati-bengals/" rel="tag">Cincinnati Bengals</a><a href="https://www.305sports.net/tag/featured/" rel="tag">featured</a><a href="https://www.305sports.net/tag/miami-dolphins/" rel="tag">Miami Dolphins</a></span></div><!--mvp-post-tags--><div class="posts-nav-link"></div><!--posts-nav-link--><div id="mvp-author-box-wrap" class="left relative"><div class="mvp-author-box-out right relative"><div id="mvp-author-box-img" class="left relative"> <img alt='' src='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9e2758f1be7751266512f8a5b388ec42?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></div><!--mvp-author-box-img--><div class="mvp-author-box-in"><div id="mvp-author-box-head" class="left relative"> <span class="mvp-author-box-name left relative"><a href="https://www.305sports.net/author/gabeglassman/" title="Posts by Gabe Glassman" rel="author">Gabe Glassman</a></span><div id="mvp-author-box-soc-wrap" class="left relative"> <a href="www.twitter.com/GabeGlassman" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a> <a href="www.instagram.com/officialgabeglassman" alt="Instagram" target="_blank"><span class="mvp-author-box-soc fa fa-instagram fa-2"></span></a></div><!--mvp-author-box-soc-wrap--></div><!--mvp-author-box-head--></div><!--mvp-author-box-in--></div><!--mvp-author-box-out--><div id="mvp-author-box-text" class="left relative"><p>Gabe Glassman is an experienced sports broadcaster, having won 5 awards in state-wide and national competitions in the last two years. Gabe spent the last 4 years at Marjory Stoneman Douglas High School with 3 of those years being the Sports Director for WMSD-TV. He has been a South Florida sports fan all of his life. Glassman is currently attending the University of South Florida as a Mass Communications Major. Gabe is excited to get the opportunity to work with the 305 Sports Crew and to write about his favorite sports!</p></div><!--mvp-author-box-text--></div><!--mvp-author-box-wrap--><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"/><meta itemprop="url" content="https://www.305sports.net/wp-content/uploads/sites/6/2020/05/6606B63D-E31C-4FEA-85A9-80A951021A01.png"></div><!--mvp-org-logo--><meta itemprop="name" content="305Sports"></div><!--mvp-org-wrap--></div><!--mvp-content-main--><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text">Click to comment</span></div><!--mvp-comments-button--><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-sec-head"><span class="mvp-sec-head">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.305sports.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" /></p><p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='25419' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!--comments--></div><!--mvp-post-soc-in--></div><!--mvp-post-soc-out--></div><!--mvp-content-box--></div><!--mvp-post-content--></div><!--mvp-post-content-in--><div id="mvp-side-wrap" class="relative"></div><!--mvp-side-wrap--></div><!--mvp-post-content-out--><section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Miami Dolphins</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://www.305sports.net/the-chiefs-owe-the-dolphins-and-its-time-to-pay/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-400x240.jpeg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-1000x600.jpeg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/the-chiefs-owe-the-dolphins-and-its-time-to-pay/" rel="bookmark">The Chiefs Owe The Dolphins And It’s Time To Pay</a></h2><p>You read that right. The Kansas City Chiefs owe the Miami Dolphins, and head...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/kyle-van-noy-glowing-about-dolphins-on-pat-mcafee-show/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-400x240.png" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-400x240.png 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-1000x600.png 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-80x80.png" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-80x80.png 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/kyle-van-noy-glowing-about-dolphins-on-pat-mcafee-show/" rel="bookmark">Kyle Van Noy Glowing About Dolphins On Pat McAfee Show</a></h2><p>Fresh off a three-sack performance, which he called while mic&#8217;d-up, Kyle Van Noy spoke...</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/afc-east-rundown-week-13/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/afc-east-rundown-week-13/" rel="bookmark">AFC East Rundown &#8211; Week 13</a></h2><p>Week 13 was almost a clean sweep for all of the AFC East teams....</p></div><!--mvp-more-post-text--></li><li> <a href="https://www.305sports.net/305-sports-staff-predictions-dolphins-vs-bengals/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1287102725.0-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1287102725.0-400x240.jpg 400w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1287102725.0-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1287102725.0-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1287102725.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1287102725.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-more-post-img--> </a><div class="mvp-more-post-text left relative"><h2><a href="https://www.305sports.net/305-sports-staff-predictions-dolphins-vs-bengals/" rel="bookmark">305 Sports Staff Predictions: Dolphins Vs. Bengals</a></h2><p>With Tua Tagovailoa back in the lineup for the Miami Dolphins, which sit one...</p></div><!--mvp-more-post-text--></li></ul></section><!--mvp-more-post-wrap--><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><!--mvp-prev-post-arrow--><div class="mvp-prev-next-text"> <a href="https://www.305sports.net/the-chiefs-owe-the-dolphins-and-its-time-to-pay/" rel="prev">The Chiefs Owe The Dolphins And It’s Time To Pay</a></div><!--mvp-prev-post-text--></div><!--mvp-prev-post-wrap--></div><!--mvp-prev-next-wrap--></div><!--mvp-sec-pad--></article><!--mvp-article-wrap--></div><!--mvp-main-body--></div><!--mvp-main-box-cont--></div><!--mvp-main-body-wrap--></main><!--mvp-main-wrap--><footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://www.305sports.net/"><img src="" alt="305Sports" data-rjs="2" /></a></div><!--mvp-foot-logo--><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://www.facebook.com/305sportss/" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/305Sportss" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.instagram.com/305sportss/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCgKo2VlQjfUeWCHXUckC2Qw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div><!--mvp-foot-soc--></div><!--mvp-main-box-cont--></div><!--mvp-foot-top--><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"></div><!--mvp-foot-menu--></div><!--mvp-main-box-cont--></div><!--mvp-foot-menu-wrap--><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>305 SPORTS ENTERPRISES, INC.</p></div><!--mvp-foot-copy--></div><!--mvp-main-box-cont--></div><!--mvp-foot-copy-wrap--></div><!--mvp-foot-bot--></footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/&amp;t=A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals -&amp;url=https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.305sports.net/a-closer-look-4-dolphins-players-fined-following-altercations-versus-bengals/&amp;media=https://www.305sports.net/wp-content/uploads/sites/6/2020/12/KDU7EHPTWJYKMOW7FMIDQPEJNE-1000x600.jpg&amp;description=A Closer Look: 4 Dolphins Players Fined Following Altercations Versus Bengals', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="/cdn-cgi/l/email-protection#cbf4b8bea9a1aea8bff68aeb88a7a4b8aeb9eb87a4a4a0f1ebffeb8fa4a7bba3a2a5b8eb9ba7aab2aeb9b8eb8da2a5aeafeb8da4a7a7a4bca2a5aceb8aa7bfaeb9a8aabfa2a4a5b8eb9daeb9b8beb8eb89aea5acaaa7b8edaaa6bbf089848f92f682ebada4bea5afebbfa3a2b8ebaab9bfa2a8a7aeeba2a5bfaeb9aeb8bfa2a5acebaaa5afebbfa3a4beaca3bfeba4adebb8a3aab9a2a5aceba2bfebbca2bfa3ebb2a4bee5eb88a3aea8a0eba2bfeba4bebff1eba3bfbfbbb8f1e4e4bcbcbce5f8fbfeb8bba4b9bfb8e5a5aebfe4aae6a8a7a4b8aeb9e6a7a4a4a0e6ffe6afa4a7bba3a2a5b8e6bba7aab2aeb9b8e6ada2a5aeafe6ada4a7a7a4bca2a5ace6aaa7bfaeb9a8aabfa2a4a5b8e6bdaeb9b8beb8e6a9aea5acaaa7b8e4"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div><!--mvp-post-soc-wrap--></div><!--mvp-site--><div id="mvp-post-trend-wrap"><div class="mvp-main-box-cont relative"><ul class="mvp-post-trend-list left relative"><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/kyle-van-noy-glowing-about-dolphins-on-pat-mcafee-show/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-80x80.png" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-80x80.png 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/Screenshot-2020-12-07-at-1.30.39-PM-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/kyle-van-noy-glowing-about-dolphins-on-pat-mcafee-show/" rel="bookmark">Kyle Van Noy Glowing About Dolphins On Pat McAfee Show</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/the-chiefs-owe-the-dolphins-and-its-time-to-pay/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-80x80.jpeg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-80x80.jpeg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/15248312-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/the-chiefs-owe-the-dolphins-and-its-time-to-pay/" rel="bookmark">The Chiefs Owe The Dolphins And It’s Time To Pay</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/afc-east-rundown-week-13/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/1289767899.0-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Dolphins</h3> <a href="https://www.305sports.net/afc-east-rundown-week-13/" rel="bookmark">AFC East Rundown &#8211; Week 13</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li><li><div class="mvp-post-trend-out relative"><div class="mvp-post-trend-img left relative"> <a href="https://www.305sports.net/yero-miamis-come-from-behind-victory-showcases-a-team-in-the-right-direction/" rel="bookmark"><div class="mvp-trend-widget-img left relative"> <img width="80" height="80" src="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/5fd01eb1017ec.image_-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://www.305sports.net/wp-content/uploads/sites/6/2020/12/5fd01eb1017ec.image_-80x80.jpg 80w, https://www.305sports.net/wp-content/uploads/sites/6/2020/12/5fd01eb1017ec.image_-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></div><!--mvp-trend-widget-img--> </a></div><!--mvp-post-trend-img--><div class="mvp-post-trend-in"><div class="mvp-post-trend-text left relative"><h3>Miami Hurricanes</h3> <a href="https://www.305sports.net/yero-miamis-come-from-behind-victory-showcases-a-team-in-the-right-direction/" rel="bookmark">Yero: Miami&#8217;s Come From Behind Victory Showcases A Team In The Right Direction</a></div><!--mvp-post-trend-text--></div><!--mvp-post-trend-in--></div><!--mvp-post-trend-out--></li></ul> <span class="mvp-post-trend-but fa fa-angle-down mvp-post-trend-but-click" aria-hidden="true"></span></div><!--mvp-main-box-cont--></div><!--mvp-post-trend-wrap--><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><!--mvp-fly-top--><div class="mvp-fly-fade mvp-fly-but-click"></div><!--mvp-fly-fade--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>/* <![CDATA[ */
var mdp_deblocker = {"style":"compact","timeout":"0","closeable":"true","title":"It Looks Like You Have AdBlocker Enabled","content":"<p>Please disable AdBlock to proceed to the destination page.<p>","bg_color":"rgba(0,0,0,0.65)","modal_color":"rgba(255,255,255,1)","text_color":"#23282d","blur":"true"};
/* ]]> */</script> <script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script> </body></html>